Windows 7 RC doesn't shut down

Discussion in 'Windows, Linux & Others on the Mac' started by Hellhammer, May 10, 2009.

  1. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #1
    So, I installed Windows 7 RC to my iMac yesterday. I installed all updates and rebooted it and it was fine no problems at all. Then I installed anti-virus program called F-Secure (it's a good finnish program, been running it on 4 other computers) and I rebooted again. Now it doesn't shut down. It just stays on "Shutting down" text and the circle is running. I had this same problem on my PC laptop.

    This isn't a big issue but I'm afraid to hold down the power button to shut down my Mac every time I use Windows.

    If anyone else is having this problem, all help is appreciated.
     
  2. NextTuesday macrumors member

    Joined:
    Aug 31, 2006
    Location:
    Cork, Ireland
    #2
    Sounds like F-Secure. Remove it and try again?
    It might not support Windows 7 yet is all.
    A good alternative (and free) is AVG Anti-Virus.
     
  3. Hellhammer thread starter Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #3
    It shouldn't. My PC did the same before I installed it and F-Secure costs 70€ per year and it's good. I'll remove it and try again...
     
  4. justflie macrumors 6502a

    justflie

    Joined:
    Nov 29, 2005
    Location:
    Red Sox Nation
    #4
    I'm using Avast antivirus and W7 shuts down really fast with no hanging. If you were running the Windows 7 beta (build 7000) and upgraded to the RC, that could be the issue also. Many people in the know have recommended a complete reinstall (wipe the old windows out and start over).

    But in this case, it sounds like the AV you installed is the culprit.
     
  5. markojug macrumors regular

    Joined:
    Mar 16, 2009
    Location:
    In A House, Ontario, Canada
    #5
    Have you considered to use VMWare or Parallels instead? No need to hard boot your Mac cause of Windows 7. Costs a bit but it is very good...
     
  6. Hellhammer thread starter Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #6
    I just booted in safe mode and everything was fine and shutted down in few seconds. As I said, F-Secure shouldn't be a problem because It owrked fine on my PC.

    Now I have another problem. My network is 4 bars out of 5 so it should be fast but it takes ages to load any page in Windows. No matter which browser I use. First 10 minutes it's very slow but now it works perfectly. Why?
     
  7. Hellhammer thread starter Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #7
    I rebooted on Windows again and it didn't shut down -> had to push the power button. Then I booted to Windows again and ended all F-Secure processes -> still no go, didn't shut down.

    I rarely use Windows but it would be nice that it is not going to harm my Mac because forcing to shut down isn't good for computer.

    I'm just clueless what to do :confused:
     

Share This Page