Windows 7 stuck on Welcome Screen - HELP!!!

Discussion in 'Windows, Linux & Others on the Mac' started by Canuckk, Jun 23, 2010.

  1. Canuckk macrumors newbie

    Joined:
    Jun 29, 2008
    #1
    So I just installed a legit copy of Windows 7 Ultimate on my new 13" MacBook Pro via Boot Camp. It worked fine at first, as in on the first boot up it was fully functional but still needed the Windows on a Mac drivers from the OS X CD installed. So I installed them and restarted, only to find that when I try to login, the computer freezes on the "Welcome" loading screen. I've tried completely reinstalling twice now, and tried booting in safe mode, but nothing so far has worked. I googled the problem and found nothing helpful, and couldn't find anything on a search in MacRumors. This is really frustrating me as I need to use Windows for several applications that aren't available on Macs. Anyone have any suggestions to get this running? I'd really appreciate any help I could get, thanks.
     
  2. Canuckk thread starter macrumors newbie

    Joined:
    Jun 29, 2008
    #2
    So I did find a solution to the problem as it turns out, after a lot of research. It's a problem with the nVidia drivers on the Mac. By installing a Hotfix from Microsoft, the problem is solved. So if anyone else is having a similar issue, just do that.
     
  3. zebualvi macrumors newbie

    Joined:
    Dec 12, 2009
    #3
    Hi, ive got the same problem. I installed every microsoft update and also tried new bootcamp update but nothing worked. Ive tried both 32 and 64 bit versions. I restored windows to pre-bootcamp state which worked so its definitely bootcamp but these drivers worked before so i dont know what happened now. I reinstalled windows after i accidentally deleted my old windows partition. I have even reinstalled OS X but nada.
     

Share This Page