Windows 7 through both VMware Fusion and Bootcamp/Activation Query

Discussion in 'Windows, Linux & Others on the Mac' started by ben88, Nov 7, 2009.

  1. ben88 macrumors newbie

    Joined:
    Feb 9, 2009
    #1
    Hello everyone,

    I've recently bought Windows 7 Home Premium to run on my MacPro. Having installed it on a separate HD, I had some problems getting VMware Fusion to recognise the partition, so I contacted VMware for support. The guy managed to solve that particular problem, but then I had an activation issue. Windows thinks that it's operating on different hardware when running on Fusion, and therefore won't activate. Being as I want the option to run Windows 7 both through bootcamp and Fusion, I got back in touch with the guy. He informed me that "each license is supposed to be used under one computer. *Running the same license under a virtualized and then on a physical machine is illegal and can get you into trouble."

    Fair enough, I suppose, but I've read other things to contradict this view. Take this guy for instance (http://forums.macrumors.com/showthread.php?t=811939). He seems to have done exactly what I've done without any problems. I also had been used to booting Windows XP in both bootcamp and fusion without any issues. So can someone clarify the licensing regulations when it comes to virtualisation? Is there a way around my current predicament, without having to buy another Windows 7 license? Is it even possible to buy another software license for this purpose? Any advice would be greatly appreciated.

    Ben.

    P.S. Sorry in advance if I've missed something, but I've had a good browse on this forum and others but couldn't find a direct solution to my problem.
     
  2. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #2
    1. Install Windows.
    2. Boot into Windows natively and activate.
    3. Boot into OS X.
    4. Launch Fusion and allow it to prepare your Windows install as a virtual machine.
    5. Boot into Windows through Fusion.
    6. Install VMWare Tools.
    7. Activate.
    8. ???
    9. Profit!!!
    That's the official spiel from VMWare at any rate. YMMV. It's worked for me, but calling Microsoft and going through the God-awful manual activation will work as well.

    Now if only there was a better way to keep the activation for Office 2007...
     
  3. NT1440 macrumors G4

    NT1440

    Joined:
    May 18, 2008
    Location:
    Hartford, CT
    #3
    I'm actually on the phone right now for the same issue in virtualbox.

    I got the student pricing so I can only use the product key once. Well, its no good now, the guy is trying to get me a different product key for me to use, hopefully it goes through.

    I've been on the phone with 8 departments and 2 hours now, its annoying as hell.
     
  4. ben88 thread starter macrumors newbie

    Joined:
    Feb 9, 2009
    #4
    Thanks for getting back to me.

    First of all I think I've tried the VMware official steps you described without success. I say 'think' because I haven't tried re-installing Windows. Maybe I should do that. But wouldn't I have to deactivate Windows first? I also haven't tried the manual 'over-the-phone' activation process, because I thought that it would basically just transfer the registration over to the virtual machine side of things, and then I'd get caught in an activation loop. If that's not the case, then I'll try that as well.
     
  5. NT1440 macrumors G4

    NT1440

    Joined:
    May 18, 2008
    Location:
    Hartford, CT
    #5
    From the 2 hours ive been on the phone so far, there is no deactivation method in 7. I asked what the hell people are supposed to do if a complete crash occurs and they need to reinstall the OS.....no answer.
     
  6. corbo950 macrumors newbie

    Joined:
    Mar 11, 2011
    #6
    I am having the same issue... did have it before I think it is after the most recent validation check update.... just made me miss a due date on a paper for school :S

    @NT1440: If your OS crashes this wont be an issue. The reason it gets angry is because when you activate it records your Processors unique ID number. When you boot into VMware the Virtual processor has a different ID number. If you reinstall on the same machine after a crash the Processor ID is the same so the activation shouldn't error out.
     
  7. ben88 thread starter macrumors newbie

    Joined:
    Feb 9, 2009
    #7
    Sorry not to have kept everybody informed but I've now seemingly resolved my issue. I think my problem was to do with having Windows installed on a seperate HD to OS X, in that Windows kept thinking it was installed on different hardware when I swapped between Bootcamp and Fusion. Pretty straight forward with the benefit of hindsight, although my old XP partition seemed to work fine with the same configuration.

    Anyway I've now installed Windows on the HD no.1 (the system drive). From memory (it was a while ago) I had a few issues with activation at first. I had to call the Windows automated activation line a couple of times, but I think this was something to do with VM Tools not installing properly. I'm glad to say that now everything works fine. I can swap between the virtual machine and Bootcamp without any problems.
     

Share This Page