Windows 7 Ultimate hangs bad, and Direct X Error on COD:WaW/MW2

BSchorr

macrumors member
Original poster
Jun 7, 2009
52
0
Sioux Falls
I installed Windows 7 Ultimate, runs great and everything, but when I boot into through bootcamp, it takes anywhere from 1-2.5 minutes to get to the "Starting Windows" logo.. Not sure why this is happening.. But when I am running Mac OSX, I start up VMware Fusion 3... I starts up right away... hrmm

Also, Installed COD World at War, and Call of Duty Modern Warfare 2... Both get a Direct X error... but doesnt tell you what error it is, so you can research it.. Call of Duty 4 runs fine...

Anyone has any ideas, let me know!
 

Infrared

macrumors 68000
Mar 28, 2007
1,680
56
I have the exact same issue, I have Win7 Ultimate running through BootCamp but it's annoying how when I boot, it stays on a blank screen flashing '_' for about 2 minutes before getting to the Windows screen. I hope someone knows a solution for this!
Are you using an MBP, too?

I can say the issue doesn't occur for some other Macs I've used.
 

ayeying

macrumors 601
Dec 5, 2007
4,549
11
Yay Area, CA
I have the exact same issue, I have Win7 Ultimate running through BootCamp but it's annoying how when I boot, it stays on a blank screen flashing '_' for about 2 minutes before getting to the Windows screen. I hope someone knows a solution for this!
That's a bios hack. It literally means you pirated Windows 7. If you have a bought/legal version, it shouldn't do it. It doesn't happen on mine.
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.