Windows 7 will not recognize Network Adapter

Discussion in 'Windows, Linux & Others on the Mac' started by PurrNugget, Aug 30, 2013.

  1. PurrNugget macrumors newbie

    Joined:
    Mar 16, 2013
    #1
    So after many attempts to install Windows 7 on my late 2008 Macbook Pro (MBP5,1) running Lion, I finally got it to work. I messed around a bit on the windows side, the internet worked fine then but since I didn't have my drivers installed, nothing else Mac related worked.

    So I get the drivers from my bootcamp assistant, get them all installed, restart. Seems like all the drivers installed fine, except I can't get internet. It's not even detecting the network adapter. I went to manage devices, there is no network adapter to be seen.

    I've tried putting in my original Leopard OS disc, and my Snow Leopard OS disc, but it just kicks it back out. I assume this is because I'm now running Bootcamp 4 with Lion.

    I think I've tried every solution I can find online, but nothing seems to work. Is there anyway to manually download the network adapter driver? Or should I just wipe the partition and start all the way over? I fear doing this because I had to do so many things (mess with the info.plist, boot from USB) I might not be able to get put windows back on here.

    I appreciate any and all help.
     
  2. xcodeSyn macrumors 6502a

    Joined:
    Nov 25, 2012
    #2
    Before you wipe your partition, try the direct download link at the bottom of this page and follow the instructions to install on a USB drive under OS X. Then open the the BootCamp folder in Windows and double click the setup.exe to reinstall the drivers or just install the network adapter driver if you know which one in the Drivers folder. Not sure it would work but worth a try.
     
  3. PurrNugget thread starter macrumors newbie

    Joined:
    Mar 16, 2013
    #3
    Yeah this was the first windows support software I tried since my internet was kind of blotchy and I wasn't able to fully download the proper one from Bootcamp Assistant. This was where the internet stopped working. I tried removing and reinstalling the drivers a couple times from that one but nothing worked.

    So I went back to Bootcamp Assistant and tried downloading that one. It finally downloaded all the way. It has a different name but I was hopeful that it was slightly different and would fix the problem. After removing and reinstalling with that software package, same thing. I can't even find the network adapter in the manage devices section in Windows. Everything else works like a charm though.

    Maybe I'll try and figure out which driver I need, broadcom or something, and try that route. Thank you for you suggestion.
     

Share This Page