Windows 7 x64 + Atheros 5008X -> sleep disorder

Discussion in 'Windows, Linux & Others on the Mac' started by intealls, Aug 29, 2009.

  1. intealls macrumors newbie

    Joined:
    Aug 29, 2009
    #1
    Hi everyone.

    I'm using Windows 7 x64 on a Santa Rosa MBP which has an Atheros AR5008X wireless network card.

    It seems that when the computer has been on for a while, the wireless driver fiddles with the power management mechanism somehow and breaks sleep mode. When the computer enters sleep mode, it instantaneously wakes up again. No problems exist if the card is disabled and enabled just before entering sleep mode.

    I'm using the driver from Windows Update, dated 8th of July 2009.

    I was wondering if anyone else is experiencing this problem and has found a viable workaround?
     
  2. techmonkey macrumors 6502a

    Joined:
    Jun 8, 2007
    #2
    So your MBP wont go into sleep mode? Mine goes into sleep mode just fine but my wireless connection drops after 10-15 minutes. I try to manually reconnect and it doesnt work. A restart gets my connection back.

    Have you had that issue? I wonder if my MBP is going into sleepmode when I lose the connection, I will have to keep an eye on that.
     
  3. intealls thread starter macrumors newbie

    Joined:
    Aug 29, 2009
    #3
    I had a lot of drops in RC, haven't had any in RTM. Everything works nicely (autoconnect, N 300mbit etc) except for the sleep issue.

    The problem I'm experiencing is if the comp has been running for a while with the wireless card enabled, when the computer is entering sleep mode it instantaneously wakes up again. Think of it as pressing the sleep-button and directly hammering a bunch of keys.

    If I disable the driver and re-enable it and directly putting the computer to sleep, it works as it should.

    Are you using the Boot Camp driver or the Windows Update one?
     
  4. techmonkey macrumors 6502a

    Joined:
    Jun 8, 2007
    #4
    I am using the Microsoft one dated 6/9/2009. I have 2 other ones in the "Compatible List" under Device Manager.

    Atheros Communications Inc dated 7/8/2009 and another dated 4/15/2007

    Which driver are you using? I am running Windows 7 Professional 32bit Final. My school has a MSDN program which I was able to get the final copy.
     
  5. intealls thread starter macrumors newbie

    Joined:
    Aug 29, 2009
    #5
    7/8/2009 on x64, I don't know if the drivers differ 32->64. Probably not :)

    The only issue I'm having is the sleep stuff. But then again, wireless networking is twitchy. I'd try updating the router's firmware etc.

    As a last resort you could try snagging an x64-build off MSDN, but that doesn't necessarily mean the problems will go away :(
     
  6. techmonkey macrumors 6502a

    Joined:
    Jun 8, 2007
    #6
    I tried installing x64 but none of the drivers worked. My Leopard disc didnt have any x64 drivers. My MBP only has 2GB of RAM, so x64 wont do me any good.

    My router firmware is the latest DD-WRT release. Since I posted on this thread, my wireless hasnt gone out. Maybe its something in the air...lol :)
     
  7. techmonkey macrumors 6502a

    Joined:
    Jun 8, 2007
    #7
    my wireless connection issue seems to be something in the room causing it. I moved to another room in the my house and no drop outs.

    regarding your sleep issue, that is weird. I wonder if theres another piece of software causing it? Why do you think the wireless is the culprit?

    Off topic, where do you see your connection speed in Windows 7? It past windows, it showed it when you hovered over the sys tray icon (if I remember correctly). I want to make sure the connection is wireless N.
     
  8. intealls thread starter macrumors newbie

    Joined:
    Aug 29, 2009
    #8
    The reason I think it's the wireless card is that if I disable it, the computer always enters sleep mode without issue. If it's enabled for a period of time (say an hour), sleep breaks, and I have to disable the card and enable it again. If I put the computer to sleep directly after that, it works. Funky, I know. :)

    I'm fairly certain it's not an application that's causing it, since disabling the card and enabling it again always fixes the issue.

    You can see the connection speed by clicking the wireless tray icon, right clicking the network you're currently connected to and select Status.
     
  9. techmonkey macrumors 6502a

    Joined:
    Jun 8, 2007
    #9
    Ahh, I see. That is weird. We both have the same hardware (Santa Rosa) but I am running 32bit. Hope you can find a solution :)
     

Share This Page