Windows 8.1 blocks apple.com website

Discussion in 'Windows, Linux & Others on the Mac' started by Mac32, Nov 2, 2013.

  1. Mac32 macrumors 6502a

    Joined:
    Nov 20, 2010
    #1
    Hi bootcampers,

    It seems Microsoft isn't too pleased with Apple these days. :p I can't access the apple.com website using Windows 8.1 and Internet Explorer, running Windows 8.1 for a whole week now. Really weird...
     
  2. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #2
    I just went to apple.com on my Windows 8.1 and Internet Explorer. No issues here.
     
  3. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
  4. ChristianJapan macrumors 601

    ChristianJapan

    Joined:
    May 10, 2010
    Location:
    日本
    #4
    Works ok on my 8.1 tablet; just a bit poor rendered. Bit small, centered and lots space left and right.
     
  5. Michael Goff macrumors G3

    Michael Goff

    Joined:
    Jul 5, 2012
    #5
    turn oss compatibility mode in the settings and see if it changes... let me go see how it looks on my RT.

    It looks normal to me.
     
  6. Mac32 thread starter macrumors 6502a

    Joined:
    Nov 20, 2010
    #6
    Well, I can access apple.com when using Chrome. Hmm, I'm also having issues with USB3 not working. I had Windows 8.1 crashing a few times right after the installation, before I figured out hybrid sleep mode was the problem. Maybe some files or drivers got corrupted...
     
  7. ShaneBunting Suspended

    Joined:
    Aug 10, 2009
    Location:
    United Kingdom

Share This Page