Windows 8.1 does not recognize my iMac DVD drive

Discussion in 'Windows, Linux & Others on the Mac' started by Buffzap, Jan 29, 2014.

  1. Buffzap macrumors newbie

    Joined:
    Jan 29, 2014
    #1
    I installed windows 8.1 on bootcamp 5 on my iMac. Everything installed fine and everything works on windows EXCEPT my DVD drive on iMac? I downloaded bootcamp 5 latest drivers and installed in windows from USB and still nothing.

    The only drives that show are bootcamp and osx.

    Any suggestions please?
    Thanks
     
  2. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #2
    What year is your iMac? If 2013, you have to download the drivers through the boot camp assistant process.
     
  3. Buffzap thread starter macrumors newbie

    Joined:
    Jan 29, 2014
  4. xcodeSyn macrumors 6502a

    Joined:
    Nov 25, 2012
    #4
    The DVD drive is a "plug and play" self-configured component, just like a USB drive and no driver is required in Windows. Have you tried to load a disc in both Windows and OS X? If absent in Windows, then it would not show in OS X as well. If this is the case, you may have a defective drive or loose connection assuming it's your internal drive we are referring to.
     
  5. Buffzap thread starter macrumors newbie

    Joined:
    Jan 29, 2014
    #5
    It is the internal superdrive in my iMac. Yes I have tried both ways, does not show anything in windows 8.1 when I insert a dvd but works fine in OSX.
     
  6. xcodeSyn, Jan 30, 2014
    Last edited: Jan 30, 2014

    xcodeSyn macrumors 6502a

    Joined:
    Nov 25, 2012
    #6
    Seems like your Windows 8.1 has a problem automatically assigning the drive letter and path. Try the instruction as outlined in the 2nd post.

    Edit: Just realized that the instruction only applies to Windows 7 and before. For Win 8/8.1, you probably need to open the File Explorer window and right click on This PC icon on the left and select Manage, then follow the same instructions outlined or just follow the System and Security->Administrative Tools->Computer Management->Storage/Disk Management in the Control Panel.
     
  7. Buffzap thread starter macrumors newbie

    Joined:
    Jan 29, 2014
    #7
    Getting close. The drive is an ST3500418AS ATA drive. There is no letter under location 0 Channel 0 Target 0 Lun 0

    Following the instructions you referred me to when I right click I do not get an option to add a letter and path.
     
  8. xcodeSyn macrumors 6502a

    Joined:
    Nov 25, 2012
    #8
    You definitely selected the wrong drive to right click, ST3500418AS is a Segate HDD. If your superdrive is present, it should be listed at the very bottom in Disk Management window. The correct option is change drive letter and paths.
     
  9. Buffzap thread starter macrumors newbie

    Joined:
    Jan 29, 2014
    #9
    Fixed DVD drive.

    Step 1: Launch Command Prompt with administrator rights. To do this, switch to Start screen, type CMD and then simultaneously press Ctrl + Shift + Enter keys to launch elevated prompt. Click Yes for User Account Control prompt. You can also try other methods mentioned in our how to launch a program with admin privileges in Windows 8 guide.

    Step 2: In the elevated prompt, paste or type the following command and press enter key:
    reg.exe add “HKLM\System\CurrentControlSet\Services\atapi\Controller0″ /f /v EnumDevice1 /t REG_DWORD /d 0×00000001

    Step 3: Exit the Command Prompt, reboot your PC. You should now see the DVD drive in Windows Explorer as well as Device Manager.
    Method 2:
     
  10. ojdrew macrumors newbie

    Joined:
    Oct 30, 2015
    #10
    I had the same issue with Windows 10 and a Mid2011 iMac.
    Apparently this is a common problem.

    To fix the issue I downloaded the latest Bootcamp drivers onto a 8GB USB stick formatted to FAT32.
    From Windows open Explorer and browse to \Bootcamp\Drivers\Apple.
    Run the AppleODDInstall64 in Windows8 compatibility mode and run as Administrator.
    Reboot Windows and your Optical Drive works.

    Hope this helps you.
     

Share This Page