Windows 8.1 Pro Bootcamp Driver Woes

Discussion in 'Windows, Linux & Others on the Mac' started by Janichsan, Jul 30, 2014.

  1. Janichsan, Jul 30, 2014
    Last edited: Jul 31, 2014

    Janichsan macrumors 65816

    Janichsan

    Joined:
    Oct 23, 2006
    #1
    I recently created a Bootcamp partition on my 2012 Retina MacBook Pro, where I installed Windows 8.1 with the suggested BootCamp drivers. The installation went smooth without a single hitch.

    However, things aren't working as they should: I have no sound, the graphic drivers for the Nvidia GT 650M are only listed as "Microsoft Basic Graphics" or something like that, and the trackpad does not seem to work only on a very basic level (no multitouch, for instance).

    I have already tried to reinstall the drivers, to no avail.

    Am I missing something? The drivers I downloaded are the recent ones, aren't they? I found another version, but these are meant for later MacBook models.
     
  2. Janichsan, Aug 1, 2014
    Last edited: Aug 1, 2014

    Janichsan thread starter macrumors 65816

    Janichsan

    Joined:
    Oct 23, 2006
    #2
    Okay, thanks to the overwhelming response here (…), I was able to figure out at least some solutions.

    Fixing the missing/broken GPU driver was the least of the problem: download from Nvidia, install.

    The trackpad problem surprisingly "fixed" itself. I now have more than just the most basic functions, but Apple's driver still seem to be very rudimentary. Hence this, I presume.

    A real bummer was the sound problem, though. Installing a manufacturer provided driver was no solution, since there is none. Drivers for the correct model cannot be found on Cirrus' website. However, as I found, the problem is not driver related – it's simply due to wrong settings! In Windows' sound settings, an "USB PnP" device is set as default sound output device –*which apparently is just a figment of Windows' imagination. Selecting the correct "Cirrus" device as default enabled sound again.

    I'm still not 100% content, though: for one, there seems to be no brightness control for my rMBP's screen. The corresponding function keys don't do anything, and there does not seem to be a brightness function anywhere in the system settings.
    EDIT: Okay, forget that. Another re-boot, another thing that astonishingly fixed itself. Brightness controls now work...

    Secondly, network speed is oddly limited. I have my rMBP connected via a Thunderbolt dock to a gigabit ethernet network. The Apple provided BroadCom driver don't allow for more than 100 MBit/s, though. It's not a huge problem, but noticeable.
     

Share This Page