Windows 8 Consumer Preview 64-bit and Apple keyboard layout?

Discussion in 'Windows, Linux & Others on the Mac' started by RamGuy, Mar 13, 2012.

  1. RamGuy macrumors 6502a

    RamGuy

    Joined:
    Jun 7, 2011
    Location:
    Norway
    #1
    Finally Boot Camp assistant managed to download the right BootCamp drivers for my MacBook Air 13" 2011 model so finally I could install the BootCamp drivers in Windows 8 Consumer Preview and actually make thing usable.

    I'm faced with one slight issue, I can't seem to get the Apple keyboard layout working under Windows 8 Consumer Preview? It did install, and it did auto-load as usual but upon creating a new account in Windows 8 I can't seem to find the Apple keyboard layout under language options in Windows 8?

    I can add all sorts of keyboard layouts besides the ones whom should be added with the BootCamp drivers, making my keyboard layout locked into Windows layout making things rather confusing as Apple and Microsoft don't use the same keyboard layout.


    Have anyone else figured a way to get the Apple keyboard layouts to load using Windows 8 Consumer Preview?
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    What is so different from the Apple keyboard layout to the Windows layout, except the positions of ALT and the Windows key (which is the CMD key)?
     
  3. Grannyville7989 macrumors 6502a

    Grannyville7989

    Joined:
    Aug 2, 2010
    #3
    I've also had a similar problem on my MacBook Pro. On my self-built desktop, the keyboard was set to US keyboard layout so I had to change it manually to British, but that was easy enough to do from the Control Panel. However, if I try to do it on my MacBook Pro, I don't have the option to change it to Apple keyboard layout, like I could under Windows 7.

    This is especially annoying when I'm typing on my laptop and I have to use characters like @ and ".
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    Yeah, I always forget that. For me using the right OPTION or CMD key was useful as AltGr.
     

Share This Page