Resolved Windows 8 doesn't install through bootcamp

Discussion in 'Windows, Linux & Others on the Mac' started by Poro, Dec 11, 2012.

  1. Poro, Dec 11, 2012
    Last edited: Dec 18, 2012

    Poro macrumors newbie

    Dec 11, 2012

    So I'm having this problem that I can't install Windows 8 Pro x64 through bootcamp. I've created an installation USB on Sandisk Extreme 64gb USB3 and split the drive with bootcamp assistant. When ever I try to install windows, it says "We couldn't create a new partition or locate an existing one. For More information, see the Setup log files". Image of this has been attached. I just can't get past that point. Any idea what's going on? I'm installing this on my 15" Retina Macbook Pro. Help would be appreciated, been trying to fix this for way too long. :p

    Thanks in advance!

    SOLVED: Check post number 9 for details how this was fixed.

    Attached Files:

  2. AnonMac50 macrumors 65816

    Mar 24, 2010
    I'm not quite sure how to fix it on your computer, but I can tell you on a desktop of mine how I fixed it (it may give you an idea I hope). I was installing Windows 8 to the second hard drive, and it kept giving me that error. I found that by removing the first hard drive (or at least disconnecting the SATA data cable), I could get it to install. I then returned the drive. This may help you I hope.
  3. cutter74 macrumors member

    Nov 15, 2012
    Try to reformat the partition you want to install Windows on as NTFS and try again.
  4. Poro thread starter macrumors newbie

    Dec 11, 2012
    Hmm, I see. Seems to be a problem with Windows 8 but I can't really disconnect the other partitions, now can I? Just to clarify, it's one internal SSD with 4 partitions. Any ideas how I could circumvent this?

    I've reformatted and deleted the partition from the Windows setup quite a few times
  5. chons macrumors newbie

    Dec 11, 2012
    Try get a external drive or change partition size and see if you can solve the problem.

    Had problem also when trying to install , tried delete partition and remake NTFS partition then error can't install.. rerun bootcamp to delete/fix partition then try install 2nd time it just pass through..
  6. Fhame Rashid macrumors newbie

    Feb 11, 2011
    if you have anything connected like usb drive or sd card, remove it and then restart it, go through the installation process again and now it should work
  7. AnonMac50 macrumors 65816

    Mar 24, 2010
    I believe Windows 8 cannot be installed to a drive with more than 3 partitions.
  8. kevin14433 macrumors newbie

    Dec 12, 2012

    Thanks for all of you people I just followed your whole steps for the installation of window 8 and it works.
    I am loving it :)
  9. Poro thread starter macrumors newbie

    Dec 11, 2012
    I decided to update this thread in case anyone stumbles upon the same problem. The problem was having the USB plugged in while installing, but I had to have it there since that was my Windows 8 installation media (rMPB no optical). If you just want to install Windows 8 from USB, split the drive normally using boot camp assistant and then finish the partitioning manually by following the guide below. This will result in a messed up MBR-table tho, so if you want to add your boot camp installation to Parallels, you also have to follow the second guide on how to fix the messed up MBR. Hope this helps.

    How to solve "We couldn't create a new partition or locate an existing one."

    How to fix messed up paritition tables after that in order to boot Windows through Parallels boot camp.
  10. tallcoder macrumors newbie


    Mar 30, 2016
    Thanks! I ran into the exact same issue ... so far so good. Thanks again for posting what you found!

Share This Page

9 December 11, 2012