Windows 8 EFI won't boot up on my 2010 Mac Pro

Discussion in 'Mac Pro' started by muffinface, Jul 21, 2013.

  1. muffinface, Jul 21, 2013
    Last edited: Jul 21, 2013

    muffinface macrumors newbie

    Jul 18, 2013
    Hi Everyone, not sure what i'm doing wrong here...

    I successfully installed Windows 8 Pro on my 2010 Mac Pro, and everything to my knowledge worked fine. I rebooted into it twice, and it started up without a hitch. I then decided i'd boot into OSX and install software there first before going back into windows to update drivers and everything else.

    So I then rebooted into OS X, removed the Windows 8 CD from the tray, and installed some software, then partitioned my OS X drive (separate drive) so I could have a exFAT drive that my Windows SSD can access.

    When i tried cold booting into Windows 8 just hangs on the Blue window screen, and does nothing. I've tried several times and it stays on that screen, never booting into windows. I put the Windows 8 CD back in and it then hangs at the same screen but with the words "Pereparing Automatic Repair" but never actually does anything.

    I suspect it could be looking for my boot drive or something. Not entirely sure what happened. Hoping someone out there could help me out with a possible fix, it's giving me a huge headache!! I've been at this for a couple of days, and my Internet has been down all of Saturday.

    For reference, I have a Mac Pro mid 2010 (5,1), windows is on a Separate SSD drive installed on the 2nd optical SATA cable, while OSX is on an HDD in Tray 1.

    Thanks in advance!
  2. GP-SE macrumors 6502

    Feb 27, 2013
    maybe try a PRAM reset, or perhaps the windows partition\boot manager got messed up, might have to reinstall.
  3. chomomo macrumors member

    Oct 5, 2009
    Los Angeles, CA
    Partitions are screwed.

    Please help me summarize.

    1. Installed windows 8 > ran win updates.
    2. Boot into OSX install software on OSX.
    3. Made a separate partition OSX drive to access via wind 8 & OSX.

    Most likely the partition from the OSX drive screwed up the boot manager on the win 8 side. Try doing a repair with win 8 install disc and or running the check disc using the repair( could take several min~hours).

    If all fails...go back to OSX > run bootcamp > install win 8.
  4. muffinface thread starter macrumors newbie

    Jul 18, 2013
    Thanks for the replies guys, I've tried the Pram reset several times already and no go.

    @chomomo: #1 and #2 are correct, as for #3, There are no partitions as i'm running both OSX and Windows 8 on separate drives.

    I have a feeling that for some reason, the windows 8 drive can't seem to find the EFI boot info so it can boot into windows, which somehow is on a partition on the OSX drive. I'm going to try and point it towards that direction, and may solve my issue. If not, i'll try re-installing both again, and make sure that the boot info resides in the same drive as windows...I don't think it should matter, but that's the only reason I can think of as to why it stopped working.

    I'm trying not to use bootcamp but if this doesn't work out, then i'm probably going to have to. It's a shame because aside from this boot issue, everything works perfectly. :(
  5. fusion71 macrumors newbie

    Jun 14, 2013
    It is usually best to disconnect all other hard drives when installing windows, otherwise it may put its boot files on other drives (in your case, the OSX drive).

    I suggest you temporarily disconnect the OSX drive, boot with the Windows 8 DVD and run startup repair(s) on the Windows SSD.

    Only after verifying the system is able to boot successfully into the Windows SSD by itself would I reconnect the OSX drive.
  6. scottsjack macrumors 68000

    Aug 25, 2010
    I've had two successful Windows 8 EFI installations. Both were on separate hard drives with all other drives except the OD disconnected. Only after W8 was installed did I install Boot Camp using the Mac Pro's install disk, then updated that with the latest BC. I worked pretty good (2010 MP 3.2 quad).
  7. Demigod Mac macrumors 6502a

    Apr 25, 2008
  8. Game64 macrumors member

    Jan 21, 2011
    Las Vegas, NV
  9. pastrychef macrumors 601


    Sep 15, 2006
    New York City, NY
    I have Windows 8 installed on a separate drive but it took me many tries because it keeps stalling out during the install process. I suspect that my problems were due to an optical drive that was extremely near death. But after hours of trying, I finally got it installed and it works fine with vmWare Fusion.

    Eventually, I replaced my Mac Pro 3,1 with a 5,1 and transplanted the drive to the new machine and it continued to function perfectly, albeit after having to call Microsoft to reverify my serial code.

    Unfortunately, I can not describe how I did the install because I lost track of what worked after all the attempts needed to complete the install process.

Share This Page