Windows 8 USB crashes on boot

Discussion in 'Windows, Linux & Others on the Mac' started by anthodn, Feb 24, 2013.

  1. anthodn, Feb 24, 2013
    Last edited: Feb 25, 2013

    anthodn macrumors newbie

    Joined:
    Feb 24, 2013
    #1
    Hi,

    I've been trying all day to install a Windows 8 partition, with some help from BootCamp, in vain.
    I used BootCamp to make the bootable USB, download drivers and create the partition. Then, when the Mac reboots, it goes straight to a black screen displaying "No bootable device detected".
    When I restart it and try to boot on the USB Drive, first the USB is labeled "EFI Boot", which is quite not normal, and when I hit enter, it juste freezes on the drive selection screen, and I have to manually reboot it.

    I also tried with rEFIt, it shows 3 different ways to boot on my USB Drive. The bootmgr.efi didn't work, rEFIt returned an error, don't remember what it was. The bootx64.efi crashed just like it does when I selected the USB Drive through Apple boot manager. And then "Boot Windows from HD" displays the black screen and "No bootable device" message.


    Edit : The problem might certainly come from the BootCamp utility I used to make the USB Bootable. I read somewhere that Windows 8 supports EFI Boot, which I don't quite understand how it helps me, but I believe that the way BootCamp treats the USB do make a bootable Windows 7 drive doesn't work with Windows 8. So, how can I make that USB Bootable on my Mac ?
     
  2. anthodn thread starter macrumors newbie

    Joined:
    Feb 24, 2013
    #2
    I tried doing the same with Windows 7, didn't work out either. Through Alt key, the flash drive didn't show up, and rEFIt suggested two ways to boot Windows, one from HD, the other one from the flash drive. Both ended on the "No bootable device detected"..
     

Share This Page