Windows D: drive doesn't show up on networked PC

Discussion in 'macOS' started by SctClsn, Mar 2, 2009.

  1. SctClsn macrumors newbie

    Joined:
    Mar 2, 2009
    #1
    I have a (newly) mixed network - Mac OS X 10.3 and Win XP Pro. I have two internal hard drives in each machine. After downloading SharePoint I was able to see the second Mac HD from the XP machine. I can't for the life of me find any reference to accessing the D: drive on the XP machine from the Mac box.

    It seems to me that using "Finder->Go->"connect to server" forces you to log on as a user and then only gives you access to user level and below. In other words you can't get to "My Computer" to access other drives. Links don't appear to work so I can't set a shortcut (tried the "nethood" folder under the user account but they are only links and didn't get me anywhere).

    I have all sharing turned on. Can access the user folder no problem. Just can't get to upper level resources.

    I don't have much hair left to pull out - any help would be greatly appreciated.
     
  2. diamond.g macrumors 603

    diamond.g

    Joined:
    Mar 20, 2007
    Location:
    Virginia
    #2
    On windows once you turn on sharing for a root drive the share (by default) is hidden. So when you connect to the server you can tell it smb://servernameorip/driveletterorsharename$ The $ is what makes the share hidden.
     
  3. SeaneyC macrumors member

    Joined:
    Jan 27, 2009
    #3
    As far as i know, it isn't possible to share at a "my computer" level. However, as per the previous post, the C drive is shared by default under the admin account as C$, and you can share D and any other drives in the same way, either as hidden or non-hidden shares on the hostname.

    If you wish to delete the C$ admin share, you will need to play about with regedit as i believe Windows has the great idea of recreating the C$ share upon rebooting. Not great for most people and security but as a sysadmin it's rather useful.....

    You may need to turn off simple file sharing in windows depending on your install of XP
     
  4. SctClsn thread starter macrumors newbie

    Joined:
    Mar 2, 2009
    #4
    diamond.G & SeaneyC

    Thanks to you both. I had spent half a day googleing every wording I could think of in Mac & Win forums, to no avail.

    The weird thing is I had created a 'new share' for my D drive and gave it a simple name; "media". I'm sure I tried 'connect to server' using that and it didn't work. Well, it did now. I may have put it after //server/user/ . Anyway, simple enough, but again thanks for clarifying.

    By the way, it does work with smb://servername/sharename using a sharename other than the default D$.
     

Share This Page