Windows flying off the screen

Discussion in 'OS X El Capitan (10.11)' started by rogercorke, May 30, 2017.

  1. rogercorke macrumors newbie

    Joined:
    Oct 9, 2011
    #1
    Over the last couple of days windows have been suddenly flying off the screen of my Macbook.

    One second they are there and the next they are pushed to the side of the screen, with just a grey edge visible. This has never happened in the four year's I've had the Mac and it occurs both with Word documents and emails.

    I'm using OS10.11.6 with a Windows keyboard and mouse but, until this time, keyboard and mouse have worked fine with it.

    I can't work out what key I'm pressing - it seems to be random when this happens but it's probably not.

    Anyone got any solutions to stop it? Is it due to an OS update?
    thanx
    roger
     
  2. Sital, May 30, 2017
    Last edited by a moderator: May 30, 2017

    Sital macrumors 68000

    Sital

    Joined:
    May 31, 2012
    Location:
    New England
    #2
    Sounds like you're inadvertently invoking the "show desktop" command. If you use the trackpad the gesture is spreading your hand open with your thumb and 3 fingers. For the keyboard the shortcut is the F11 key.
     
  3. HenryAZ macrumors 6502

    HenryAZ

    Joined:
    Jan 9, 2010
    Location:
    South Congress AZ
    #3
    Test first the next time it happens, by hitting F11 (or Fn F11, depending on how you have your preferences set). If that brings your windows back, then either hitting the F11 key, or the trackpad thing is probably what you are doing. If it turns out to be the inadvertent trackpad gesture, you can disable the trackpad while a mouse is present. System Preferences/Accessibility/Mouse & Trackpad.
     
  4. rogercorke thread starter macrumors newbie

    Joined:
    Oct 9, 2011
    #4
    Thanks for the replies. Yes, I've discovered that hitting "Show Desktop" is exactly what I'm doing but, I promise you, not one key is activating this.

    It's happened with the Enter key, the backspace key, the forward delete key you get on a PC keyboard and even hitting an individual letter sometimes. It happens with Word documents, email and, today, an Internet page on Google Chrome. I thought it might be because I'm using a PC keyboard with the Macbook but I've had one for years with no problem.

    I also went to System preferences and switched off Show Desktop in Trackpad (even though I use a mouse instead of the trackpad). It's still happening!

    I last did an OS update to 10.11.6 on May 25. It's only been happening since then. I can't believe it's not connected.

    Any thoughts?

    Regarads
    Roger
     
  5. HenryAZ macrumors 6502

    HenryAZ

    Joined:
    Jan 9, 2010
    Location:
    South Congress AZ
    #5
    A wild shot in the dark, but you might try System Preferences/Keyboard/Change Keyboard Type. This will re-initialize your keyboard to the system.
     
  6. MultiFinder17 macrumors 68000

    MultiFinder17

    Joined:
    Jan 8, 2008
    Location:
    Tampa, Florida
    #6
    Do you have a screen corner set to activate it?
     

Share This Page