Windows <> Mac networking guru needed....

Discussion in 'Mac Basics and Help' started by mark88, May 31, 2007.

  1. mark88 macrumors 6502a

    Joined:
    Oct 30, 2004
    #1
    I have a wifi broadband router, an iMac and PC

    Router = 192.168.1.1
    iMac wifi = 192.168.1.4
    iMac ethernet = 192.168.2.4
    PC wifi = 192.168.1.2
    PC ethernet = 192.168.2.2

    I have a crossover cable connecting the 2 machines. The idea being they should be able to swap files over the ethernet cable fast and still access the internet via the router.

    It works fine on the mac side. The problem is on the Windows machine if I browse //192.168.2.4/mark/ at first it will be at ethernet speed, but after a couple seconds it will slow to wifi speeds. How can it be using the wifi interface when I am browsing the IP 192.168.2.x? given wifi is on 192.168.1.x?
     
  2. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #2
    Have you turned off wifi altogether to ensure its not a different issue?

    What exactly is wifi speed in your situation?
     
  3. Texas04 macrumors 6502a

    Texas04

    Joined:
    Jul 2, 2005
    Location:
    Texas
    #3
    Yeah I tried this.. it doesn't work... the WiFi needs to be turned off.

    That is the only solution.
     
  4. simie macrumors 6502a

    simie

    Joined:
    Aug 26, 2004
    Location:
    Sitting
    #4
    Configure both computers so that :-

    They are both using static IP addresses.

    You don't need to put in a default gateway.

    You only need the IP address and the subnet mask, the DNS server should be 172.0.0.1
     
  5. FreakinSyco macrumors regular

    FreakinSyco

    Joined:
    May 3, 2007
    #5
    Disable the wifi and re-attempt a transfer. If it still slows than the issue is not that its using the wifi for that transfer.
     
  6. mark88 thread starter macrumors 6502a

    Joined:
    Oct 30, 2004
    #6
    This worked, in case anyone was wondering +++
     
  7. ab2650 macrumors 6502a

    Joined:
    Jun 21, 2007
    #7
    172.16-31.*.* is an internal range, like 192.168.*.*; You could have alternatively used 10.*.*.* as your addresses. I'm pretty sure your problem came down to subnetting, that is, blocking out what range of addresses you're communicating with.

    From your original post, if traffic is truly going over wifi I would suspect your subnet mask is 255.255.0.0 rather than 255.255.255.0. Was this the case?
     

Share This Page