Windows Networking with OS X - have read the FAQ, but at a wall.

Discussion in 'macOS' started by Liselle, May 27, 2005.

  1. Liselle macrumors newbie

    May 27, 2005
    Hello folks, newbie here.

    I'm a long-time PC user, but I was unable to resist the temptation of the Mac Mini. I've been having fun playing with things and watching icons bounce around, but I want to migrate some of my Windows stuff over (like M2 email archives) with something a little more elegant than flopping files on the iPod.

    I've had two problems: first, I can't change my workgroup in Directory Access. I clicked the little unlock icon, it asked for my password, I clicked "Configure" for SMB/CIFS, I changed the Workgroup to something else, but clicking OK doesn't do anything. The dialog thinger just sits there, mocking me. Well, my solution to this problem was making the XP machine's Workgroup "WORKGROUP", and I hoped it wasn't case-sensitive.

    Second, even after dutifully following the rest of the instructions, they still time out when connecting to each other. Reading my Mac files from Windows I could care less about, but I tried it anyway.

    Now, I know I'm missing something obvious, here, but I can't puzzle out what it is. I'm a total noob when it comes to networking of any kind, and after spending hours last night Googling and attempting to get this to work, I give up, and have come to ask for assistance. :D

    My physical network setup is a tad unusual. The Windows machine and the mini are both connected to a switch (Linksys 10/100 5-port Workgroup Switch, to be precise), which is connected to a plain old hub elsewhere in the house, along with the cable modem and a third computer. There is no router on this setup, all three machines have "real" IP addresses. The machines can ping each other, of course, and the Windows machine is running an FTP server that I was able to log in to from the mini. Firewalls are opened appropriately, even disabling them completely (on both machines) does not do the trick.

    I've read all of the documentation I can find, and am still confused. :confused: Can anyone shed any light on the subject?
  2. Xiabelle macrumors newbie

    May 17, 2005
    Do you get any error messages? When I was connecting mine (Computers plugged into a router, which was attached to the cable modem), I had tons of trouble. They both went nicely into the workground. However, I kept getting error 36 messages and the windows machine would never throw a connection dialogue up for me. Finally, I realized that I didn't have file and print sharing enabled on the PCs network connection. Once I did that, boom, it worked.

    I honestly don't remember how I got the PC to see the Mac; it just started working at some point in the process.

    (And I have to mention it's funny to see the name Liselle, since I actually used to go by Liselle online, years ago.)
  3. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Hmm... it sounds like you're trying to do everything right, and so far as I know it should be working for you--I've always done pretty much what you're describing, and it works fine.

    I'm assuming you're running Tiger, but if you're using 10.3 this should be pretty much the same. First off, just to make sure, have you installed the latest software updates (10.4.1 or 10.3.9)?

    I've never had any trouble authenticating and changing the workgroup using Directory Access, so that's a rather odd problem. I assume hitting "return" doesn't do anything different, right? An alternative way of changing the workgroup would be to download a piece of shareware called SharePoints--it lets you configure just about anything there is to configure with filesharing on your Mac. Try that out.

    But in any case even if they're both just at the default "Workgroup" it should work (and no, workgroups aren't case sensitive). Double check that you've actually got Windows file sharing enabled on your Mac (System Preferences, Sharing panel and the SMB checkbox in Directory Access), and file and printer sharing enabled on your Windows box (forget where it is... network settings, I think). Turning off both firewalls, as you've done, is a good idea while you're testing to eliminate one source of confusion.

    At that point, if you browse your Network in the Finder, you should see the workgroup, and once you open that, after a bit your PC should pop up.

    Alternately, try the Connect to Server dialogue (Go menu or command-K in the finder) and type in smb://[IP address or computer name]/[PC's sharename] (if you're using fixed IP addresses, try using the IP address, and don't forget to enter the sharename you set up for the particular shared directory in Windows, or it won't work). It's also possible to enter addresses using a format something like \\address\sharename, but I can't remember exactly what it is right now--you might look it up (try Help) if the other doesn't work.

    If all that fails, I'm not sure what's going wrong. If you can get the PC connected to the Mac, you can always copy your files the other direction--it's faster than using CDs.

    One other thing you could always try, just for the heck of it: Both the MacOS and Windows XP support networking over firewire, so if youv'e got a firewire port on your PC and a cable around, you could try to get that working. The procedure should be pretty much identical, you just need to set up a network interface for the Firewire.
  4. Liselle thread starter macrumors newbie

    May 27, 2005
    Thanks for replying, folks. :D

    Yes, I am running Tiger. This mac mini is fresh out of the box as of Thursday, and the first thing it did on startup is update to 10.4.1.

    Hitting return in Directory Access does the same thing as clicking OK: bupkis. The Cancel button works just fine, though. It's sort of weirding me out, since I don't get an error message, or a crash, it just refuses to obey me, and I don't understand why. I don't mind leaving it as Workgroup, but it's still a tad irritating, I haven't had it long enough to break. I will try that software if I need to change things at some point.

    Windows Sharing is checked off in System Prefs (only thing that is, actually), I've selected my account as being able to use it, and the service is turned on. SMB is checked off in Directory Access. File and Printer Sharing is turned on in Windows as well as I can determine (in the properties window of my Local Connection in Network Properties or somesuch), I was able to share a test folder and see the icon get the telltale hand underneath it. I also made sure the Windows user I use was given a password.

    The only thing I see under Network in Finder is "Library" and "Servers". Servers contains the mac, and nothing else. On the third computer (one attached to the hub in a different physical location), I saw that earlier today in Network, because I shared a folder down there too. The difference is, I didn't see "Workgroup", I saw the computer name, and when I tried to open it, it failed. So that's two Windows machines that I can't access, although I came close with one.

    I tried doing a direct Connect to Server (first thing I tried, actually), but that didn't work either. I used the IP address, the computer name, even a liselle.domain.tld sort of thing that points to the IP addresss, to no avail. I added the share name at the end, it's "test" on one computer and "wallpaper" on the other, so I couldn't possibly bork it up. Just to make sure I wasn't going insane, I did smb://, and I got a nice pretty username/password dialog box. So I think I am getting the syntax right.

    My PC does have a FireWire card in it (thanks iPod!), but I don't have a cable, so that's a last resort sort of thing. Tomorrow, just for grins (or tonight, we'll see how long Dr. Pepper keeps me going), I'm going to connect them directly by Ethernet cable. I'm told that while Windows will be confused because it's not a crossover cable, the mac will figure it out. That's good enough. Assuming it works, the problem is probably hardware. If it doesn't, I am back at square one. /sigh

    Thanks for the helpful advice, I will keep throwing things at the problem until something sticks. I would really like to get the max and PC talking to each other. :(
  5. Liselle thread starter macrumors newbie

    May 27, 2005
    I've given up on getting it to work through the network. There's now a nice shiny FireWire cable running between the PC and the mac. Can anyone point me at some documentation I could read on how to get them talking? Google not terribly helpful. :/
  6. trainguy77 macrumors 68040

    Nov 13, 2003
    This may be silly but, do you have windows file sharing turned on?(on the mac)

Share This Page