Windows not installing device driver, can't restore

Discussion in 'iPad Tips, Help and Troubleshooting' started by Slip Jigs, Aug 13, 2011.

  1. Slip Jigs macrumors 6502a

    Joined:
    Feb 18, 2008
    #1
    iPad 2, started with cable icon indicating to plug not iTunes when ported on. Windows unable to load driver, tried different ports. Updated iTunes to latest version, then driver would load and iTunes saw it in recovery mode. Proceeded with restore, but it get to about 20% and hung there, even after a couple hours. Closed everything out, now it's back to the original problem where the driver won't load.

    Any fix for this or do I need to make a visit to the Apple store?
     
  2. Cooolpenner macrumors regular

    Joined:
    Jul 8, 2011
    #2
    Try to completly (!) uninstall iTunes and all its compnents (Quicktime, Mobiledevicehelper...). Then reinstall the latest iTunes version.
    You can also try it on another computer.
    If nothing helps, you'll have to go to an apple store
     
  3. Slip Jigs thread starter macrumors 6502a

    Joined:
    Feb 18, 2008
    #3
    Thanks for the response. I've actually never had to uninstall iTunes before, usually have gotten away without having to do it. Makes me a little nervous because of all the issues I've read about and heard about when restoring the library, etc. But I'll give that a try, it does make sense, but first I'll do a little research on backing up the library first, and thing like that.

    Thanks again!
     

Share This Page