Windows PC not recognizing Mac formatted HD.

Discussion in 'Mac Accessories' started by aaquib, Jun 24, 2008.

  1. aaquib macrumors 65816

    aaquib

    Joined:
    Sep 11, 2007
    Location:
    Toronto, Canada
    #1
    I have a Seagate Freeagent 250GB external HDD that was formatted for the Mac. So, I instead went to disk utility, then erase, then went to MS-DOS(fat) and let it partition it for Fat32(right?). But, my PC doesn't detect the hard drive. Neither does my PS3. When I right click on the partition in disk utility it says format: fat32, but none of my devices can detect it. Any idea on what to do?!????
     
  2. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID
    #2
    I dont know if this will help, but go to partitions in Disk Utility and then go to options. See what the partition map is. You should probably change it to MBR if it is not already, then tell it to make one partition and see what happens
     
  3. aaquib thread starter macrumors 65816

    aaquib

    Joined:
    Sep 11, 2007
    Location:
    Toronto, Canada
    #3
    There's only 1 partition on the hard drive. I really can't understand what might be wrong.
     
  4. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID
    #4
    I know there is only one partition, but the partition pane doesn't force you to make more than one. This just gives you the option to pick between GUID and MBR. The option just happens to be in that pane. It won't hurt to try.
     
  5. aaquib thread starter macrumors 65816

    aaquib

    Joined:
    Sep 11, 2007
    Location:
    Toronto, Canada
    #5
    Edit: Never mind, I did what you said and it worked flawlessly! Thank you very much normar!
     
  6. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID
    #6
    Open Disk Utility
    Click on the HD you wan to edit (on the left)
    Make sure it is the full HD selected, not just the single partition
    Click Partition (near the top of the pane, next to erase and first aid I believe)
    Click 1 Partitoin from the drop down menu
    Go to the bottum of the pane and select "Options"
    Make sure MBR is selected
    Then click whatever the button is to start the format on that pane

    If that doesn't work, try the third option (Not MBR or GUID, but the third one)

    Let me know if that works
     
  7. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID
    #7
    It works with the windows PC and the PS3 now?
     
  8. aaquib thread starter macrumors 65816

    aaquib

    Joined:
    Sep 11, 2007
    Location:
    Toronto, Canada
    #8
    Yes. Thank you!
     
  9. nomar383 macrumors 65816

    nomar383

    Joined:
    Jan 29, 2008
    Location:
    Rexburg, ID

Share This Page