Windows RDC issues

Discussion in 'Mac OS X Server, Xserve, and Networking' started by diane143, Feb 17, 2012.

  1. diane143 macrumors 6502a

    Joined:
    Oct 25, 2008
    #1
    I posted a couple of week back about attaching to a Windows 2008 Server through SonicWall (using NetExtender)

    We did get this up and running and I tested it first at the clients location and then from my house.

    Last week it wouldn't connect (SonicWall would but RDC would fail). The client told me he was VPNd in and all was working, so I rebooted and all was well.

    He installed QuickBooks this week and I needed to test that. Tonight I tried to log in and same issue, I can connect via SonicWall but RDC fails.

    This is on a 2008 unibody MB running 10.5.8 and I was running RDC 2.01

    I then tried it on my G4 FW800 running 10.5.8 (not sure of the RDC version) and logged in fine, but anytime I touched the keyboard, RDC would crash. I could click on anything I wanted but any keystroke would crash me right out.

    Fast forward a few hours and I have my laptop somewhere else. I downloaded the latest version of RDC and logged in fine to the Windows 2008 server, fired up QB and was able to mouse AND use the keyboard.

    All is well??

    Except I can't do it again. I exited and can once again connect via SonicWall but not at all through RDC - either version.

    I have looked through old threads and see there are some Airport issues. I do have an Airport Express at home but not where I am now. My G4 has a wired connection and I have been using wireless on the laptop. Both home and where I am now are using Comcast for a provider. Not sure what network the W2008 Server is on but he has a bunch of employees that regularly VPN in with no trouble (I am the only Mac user though).

    I will reset my modem etc tomorrow and can even plug the laptop into the network via cable, but I can't understand why it worked one minute here and won't do it again. Or for that matter, why I could log in last week, or log in on the G4 and not on the laptop.

    Also, I have another job where I've been using RDC for over 2 years and it is still working fine (tested both RDC versions), though I am logging into an XP machine rather than a Windows server.

    Any help would be greatly appreciated. I am supposed to be Skyping with this client tomorrow to take over his invoicing and it's not going to work if I can't get in. :(
     
  2. pismobrat macrumors regular

    Joined:
    Aug 13, 2007
    #2
    Hey

    Welcome to the world of DNS.

    There are a couple of things you need to do.

    - Add the DNS server of the network your trying to access to your network settings
    - additionally you can access the server by IP, I presume you've been trying it by name in RDC?
     
  3. diane143 thread starter macrumors 6502a

    Joined:
    Oct 25, 2008
    #3
    Thanks. It's been about 8 years since I've dealt with DNS stuff though it's coming back to me quickly.

    In NetExtender I am accessing it my IP:port

    Then in RDC I have the internal IP address in the computer name field, but the domain is the name itself. With the other client I use RDC for, I am using an IP in both fields. I can try to put the internal IP into the domain field to see if that helps.

    It obviously also has something to do with my own network as that's where I have the most trouble. I tried to log in yesterday from another location and that worked fine - 3 times.

    If I have to add the DNS server of his network, that's under System Prefs/Network/Airport/DNS - correct?

    Still not sure why any keystroke is crashing it on my desktop. I can move around just fine till I touch any key.

    Thanks so much and wish me luck!
    Diane
     

Share This Page