windows shared folder problem on mac

Discussion in 'Mac Basics and Help' started by strider21, Mar 5, 2011.

  1. strider21 macrumors newbie

    Joined:
    Mar 5, 2011
    #1
    Successfully connected a Windows 7 shared folder on a macbook pro13 running Snow leopard using smb command. The PC is connected to the MBP via an Ethernet cable.
    The problem is that many subfolders in the shared windows folder are not displayed on mac. ( there are 144 subfolders of which only 71 are displayed ). :confused: Weirdly these subfolders which are not displayed can be accessed on the mac when the smb command is used.
    example :
    • smb://pcname/foldername : mac and pc is connected but some subfolders are not displayed

    • smb://pcname/foldername/subfolder (not displayed in 1) : mac and pc connected, also the contents of the subfolder can be accessed

    This is creating problems while syncing with rsync. Only those few subfolders from the shared windows folder are copied to my mac, have to manually copy the others (which are deleted in the next sync, since mac is not seeing those subfolder!!:eek:). This issue is persistent in all Windows shared folders and drives mounted on my mac. any solutions?:(
     
  2. Rhyalus macrumors 6502

    Rhyalus

    Joined:
    Mar 4, 2011
    #2
    I am having similar problem, perhaps in the opposite direction.

    I decided to share the directory from the MBP, and then access it FROM my Win7 PC.

    Thus I did not see your problem.

    Instead, when I try to share the directories from the Mac, the subdirectories are not included... I would have to go to EACH one to assign read/write privs to the account that I added.

    Surely there is a way to assign R/W privs for all subdirectories?

    I am using syncback on the PC to synchronize the PC and the MBP.

    R
     
  3. Wake Rider macrumors newbie

    Joined:
    Mar 5, 2011
    #3
    Hey, that exact same problem happened to me! So if anyone has the answer, that would be awesome! :D

    I haven't tried this and don't know the source, but I saw somewhere that it had something to do with the permissions. Turn on the inheritable folder permissions in the windows sharing settings (so folders will inherit their parents' permissions) and ensure that the Mac has permission to access them.

    ^ I have no idea if that is causing the problem or will work.
     
  4. Rhyalus macrumors 6502

    Rhyalus

    Joined:
    Mar 4, 2011
    #4
    Well - I kind of fixed my issue for now, but I am not sure if I will have to repeat this action, depending on which computer creates the subfolder.

    I went to finder and then clicked on File / Get info.

    At the bottom you can unlock for changes (I missed this at first), change the permissions, and then click on the gear and click "apply to enclosed items".

    Now my sync works.

    So to OP, you may want to share from the Mac and sync on the PC side.

    R
     
  5. Rhyalus macrumors 6502

    Rhyalus

    Joined:
    Mar 4, 2011
    #5
    This is actually pretty annoying.

    Every time I add a directory on one machine or the other, I have to go back to the root directory of the share and apply the permissions to all enclosed items on the Mac. :mad:

    Once I set the permissions to belong to both accounts, shouldn't it stay that way for all subfolders?

    How can I force this?

    Thanks in advance,
    R
     
  6. Rhyalus macrumors 6502

    Rhyalus

    Joined:
    Mar 4, 2011
    #6
    Bump....

    Does anyone know how to assure that all new subfolders created inherit the same ownership as the parent, so I do not have to do it manually from the Mac interface?

    Thanks,
    R
     

Share This Page