Windows Shared in Finder Sidebar (yes, again)

Discussion in 'Mac Basics and Help' started by deputy_doofy, Jun 19, 2008.

  1. deputy_doofy macrumors 65816

    deputy_doofy

    Joined:
    Sep 11, 2002
    #1
    I know this has been asked on numerous sites, with some differences, but I cannot find an answer, no matter how many ways I google it.... and Apple's discussion boards have not yet helped.

    From 10.5.0 to possibly 10.5.2, shared volumes would sporadically show up in the sidebar. However, now (and not sure if this started with 10.5.2 or 10.5.3), ONLY Mac shared volumes will show up. Leopard will not show me any Windows shared volumes.

    This is quite frustrating because my Powerbook with 10.3.9 sees the Dell in our place and so does my G5 running 10.4.11. Just go to the Network folder and there it is, along with all the Macs. Leopard will only mount the Dell volume through "connect to server," followed by entering in the Dell's IP address.

    I have tried rebooting the computers, the router, enabled NetBIOS for whatever reason on the Dell, but nothing makes 10.5.3 see this Dell without manually connecting to an IP.

    Lastly, I know the MBP is at fault because I tested it at a friend's house. He, too, has the same MBP as I do, with 10.5.3 also. He sees everything; I only see the Macs.

    I really don't want to go through the hassle of archive and install. Does anyone have anything I might try?

    I've thrown out preferences galore and still nothing.

    Thanks.
     
  2. upsguy27 macrumors 65816

    upsguy27

    Joined:
    Jun 25, 2007
    Location:
    Arizona
    #2
    I had the same problem with my MacBook. I finally just gave up, because it was just too much of a hassle. If someone knows of a fix, please tell us.
     
  3. deputy_doofy thread starter macrumors 65816

    deputy_doofy

    Joined:
    Sep 11, 2002
    #3
    Just tried to reset the PRAM. Still nothing. :(

    Edit:

    Well, the pseudo-good news is, turning off the firewall and allowing all incoming connections allows the Win shares to be seen. That is the only option that works. I thought I tried that already, but maybe I didn't relaunch the finder. Well, not a perfect solution, but better than "connect to server." Ok, so... Apple needs to fix the firewall. I'll consider my question answered for now.
     
  4. tsice19 macrumors 6502a

    tsice19

    Joined:
    Feb 16, 2008
    #4
    For me, it's quite hit or miss.
    What you can try to do, though, is on the desktop PC, open up Run, type "cmd", and, in the command line type
    Code:
    ipconfig
    . This will give you the IP Address of that machine.

    Then, on the Mac, open up Finder. Click "Go", and "Connect to server." Type in the IP Address there.

    Another thing you could try, is open up "Go" and "connect to server" and type in afp://workgroup here\computer name here.

    That's pretty much what I did, and now my Windows Server and Dell PC both show up.
     
  5. dalvin200 macrumors 68040

    Joined:
    Mar 24, 2006
    Location:
    Nottingham, UK
    #5
    i'm trying to do all the above but none of it it working..

    i'm on my macbook with 10.5.3 and my dad has his vista laptop..
    both are connected to a wireless network no problems..

    the vista laptop and macbook just cannot see each other..

    i've tried connecting to server by workgroup/laptopname and also by the ipaddress, but nada :(

    nothing shows up in the finder sidebar either..

    a bit of googling points to a "windows sharing" option in the system prefs, but i can't seem to find that (was that pre-leopard?)

    any other ideas?
     
  6. tyr2 macrumors 6502a

    tyr2

    Joined:
    May 6, 2006
    Location:
    Leeds, UK
    #6
    In Leopard. 'System Preferences' / 'Sharing' / 'File Sharing'

    Then click the 'options' button in the bottom right. Then select "Share files and folders by SMB".

    You should then be able to mount on the Vista machine.
     
  7. dalvin200 macrumors 68040

    Joined:
    Mar 24, 2006
    Location:
    Nottingham, UK
    #7
    no go :(

    i've done smb://vista_address_her but still cant connect :( and also vista cant see macbook
     
  8. tyr2 macrumors 6502a

    tyr2

    Joined:
    May 6, 2006
    Location:
    Leeds, UK
    #8
    What I was suggesting was to allow access from Vista to the MacBook. As that's still not working, go to 'Security' in 'System Preferences', then 'Firewall'.

    Ensure it is set to 'Allow all incoming connections' or 'Set access for specific services and applications'. If the latter ensure that 'File Sharing (SMB)' is in the list.

    You may want to try setting the firewall to 'Allow all incoming connections' to test and see if you can then see the MacBook from the Vista machine.


    Regarding connecting from the MacBook to the Vista machine, I'm don't know much about Vista networking, but you should check that the firewall is configured correctly there as well.
     
  9. tsice19 macrumors 6502a

    tsice19

    Joined:
    Feb 16, 2008
    #9
    OK. Make sure your share is configured correctly and it's internet connection is going strong. On the mac, reset the network. As I said before, Leopard tries to do it itself, so it's hit or miss.

    Has anyone considered Windows Workgroups? That could be a problem...
     
  10. patrickmacrumor macrumors regular

    Joined:
    Jun 24, 2008
    #10

Share This Page