Windows Shares in Finder

Discussion in 'Mac OS X Lion (10.7)' started by jaipal2004, Jan 19, 2012.

  1. jaipal2004 macrumors newbie

    Joined:
    Jan 19, 2012
    #1
    Hi,

    I have a Macbook with Lion installed.

    When using the Mac at work in a windows environment I see other shares available in finder automatically that I can then connect to.

    When I attempt to use the Mac at home - none of my Windows Home Server 2008 shares show up. I can access them by going to the 'connect to server' link but cannot understand why they don't show up in finder?!

    The 'computer browser' service is started and automatic on the home server and that seems to be the solution on the net.

    Help!!
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    What do you have your WORKGROUP set to?

    (WINS tab in Network System Preferences).

    B
     
  3. jaipal2004 thread starter macrumors newbie

    Joined:
    Jan 19, 2012
    #3
    Wow!! I knew this was a good forum but didn't expect things to move so quickly :)

    It's set to 'WORKGROUP' which is also the same as my WHS
     
  4. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #4
    Well I guess it's not the easy answer then. ;)

    A common problem for WINS name resolution is having two master browsers they have an "election" between themselves to figure out who is going to manage things and sometimes the wrong one wins.

    You should be able to poke around on the command line to figure it out, but I'm afraid my Samba-fu is out of date.

    B
     
  5. jaipal2004 thread starter macrumors newbie

    Joined:
    Jan 19, 2012
    #5
    I've installed a WINS server on my WHS but not configured it. But just noticed that in the DHCP scope my router gives out no WINS server is defined either. Is there something that can be done at the router? Can my router act as WINS server?

    thanks
     
  6. prisstratton macrumors 6502

    prisstratton

    Joined:
    Dec 20, 2011
    Location:
    Winnipeg
    #6
    I have a mix of operating systems on my network at home (Mac OS X, Win7, WinXP, Linux) and one thing I did that helped, was to enable file sharing using SMB.

    System Preferences >> Sharing >> File Sharing >> Options >> Share Files and Folders Using SMB.

    This definitely helped display the window's shares in Finder and allows me to easily browse to them, although the converse is not true. I always had difficulty going from the Windows box back to the Mac, but I was not too concerned as I have the connectivity I require when I need it.
     
  7. jaipal2004 thread starter macrumors newbie

    Joined:
    Jan 19, 2012
    #7
    Already on mate :) still no difference, even when I turn it off and then back on!

    Can't help thinking it's my router??
     

Share This Page