Resolved Windows USB printer shared over Airprint for IOS 7

Discussion in 'Windows, Linux & Others on the Mac' started by zizi rider, Oct 24, 2013.

  1. zizi rider, Oct 24, 2013
    Last edited: Oct 28, 2013

    zizi rider macrumors newbie

    Joined:
    Oct 24, 2013
    #1
    For people who wants to try or people who had the Airprint.exe working for IOS 4.2 till IOS 5 and may be IOS 6 but stopped after upgrading to IOS7 :

    My setup :
    HP Officejet 6110
    Desktop Windows 7 Ultimate
    iPhone 4 with IOS6
    iPhone 4 with IOS7
    iPad1 with IOS5.1.1

    Airprint (location : C:\Program Files\AirPrint) :
    Airprint.exe (last modified 25/10/2012 – 230KB)
    libairprint.dll (last modified 25/10/2012 – 238KB)
    XpdfPrint.dll (last modified 25/10/2012 – 1,506KB)

    Bonjour service (a new version from apple website may work too):
    dns_sd.jar (last modified 30/08/2011 – 17KB)
    mdnsNSP.dll (last modified 30/08/2011 – 119KB)
    mDNSResponder.exe (last modified 30/08/2011 – 382KB)

    Guest account used : my own one

    Windows Firewall requirements :
    Bonjour service : allowed
    Airprint service : allowed
    UDP Port 5353 (mDNS protocol) on the Firewall : allowed

    Here is my story ::)

    HP officejet USB printer shared on a Windows 7 32-bit system working from iphone 4 with IOS7, iphone 4 IOS6 and iPad 1 IOS5.1.1
    After I lost this feature when I upgraded my iphone from IOS5 to IOS6, I could get it work back after my better half had broken her iphone 4 and had it replaced by a new one for 200$ in an Apple Store. The problem when I restored the backup, made a few days before, she figured that she lost the connection to our printer over the network. Indeed, I had upgraded her iPhone from IOS5 to IOS6 and could still see the printer over the network all this time which was neat for her! Since this replacement last week, no Airprint printers was available from any iphone or iPad1 (used iPad bought last August. Very good condition). That said, I started to figure why my wife could still having the printing capability from her iphone upgraded to IOS6 and lost it when I did mine. Now my iPhone has IOS7 and still could not print.

    My steps :
    In order to be clear, I will show you what I did but it does not mean it will work for every setup you may have (IOS versions; type/model of printer; Host windows version;…). What I mean is it worked for me and these following steps could be a good start to figure what could work for you.

    Step1 :
    Recall that it used to work for my wife’s iPhone 4 (IOS6) till she broke it last week.
    So Airprint and Bonjour are still installed and running as services on the computer from which the printer is shared.
    Thus, I tried to figure what stopped the Apple devices finding the printer (No Airprint printers found). First I think a track was memorized in the iPhone even after the upgrade to IOS6 for my wife’s iPhone. For mine, I may have had cleared some cache or other network information on my iPhone so that I lost this information and could not print anymore when I upgraded to IOS6. Anyway, started to use Wireshark network tool to catch the request from the new iPhone and found that a query was made with _universal._sub._ipps._tcp. Local, “QM”…
    I looked on internet to know a little bit more about this protocol and how it works. I have found different information about Airprint and one referred to the way to set Airprint service from a command line : www.airprintactivation.com (bottom of the document)
    It is an old document that I probably used the first time I installed the feature while using IOS4 or IOS5. Anyway, I saw that the command line mentioning “_ipp._tcp,_universal”, so I deleted Airprint service in order to recreate it and I reinitialized my printer sharing (delete/recreated). Then I recreated the Airprint service but, instead of “_ipp._tcp,_universal” , I put “_universal._sub._ipps._tcp “ in the command line as it was what I found out in Wireshark while monitoring the network during an Airprint search from my wife’s iPhone. Then I stopped/restarted Bonjour service and started the Airprint service.
    From my wife’s iPhone, I tried to Print something : failed, No Airprint printers found! I double checked Bonjour and Airprint Services : both still started.

    Step2 :
    I had a look at the network settings :
    Looked at the Netbios feature in network settings (Netbios over TCP/IP)  Network settings / network card / ipV4 / Advanced / WINS / Netbios setting : Default
    As I have a static IP on that computer, I set it to Enable Netbios over TCP/IP
    I restarted the services (Bonjour/Airprint) and made a new try from the iPhone : failed, still no Airprint printer detected
    Step3 :
    As initially the command line for Airprint service used to work, I deleted the Airprint service again and recreated it exactly the same way as mentioned at the bottom of the instructions on www.airprintactivation.com. So I kept the original command line.with “_ipp._tcp,_universal”
    Restarted Bonjour and Airprint services then tested from the iPhone : SUCCESSFUL, I can see my printer (need to authenticate once with the guest account though to print for the first time)!!!. Then I rushed on my iPhone (IOS7) : SUCCESSFUL!!! The iPad (IOS5.1.1) : SUCCESSFUL too!!!
    I had my wife printed something from the iPad : successful. Then I tried from her iPhone (IOS6) : successful too!
    So finally, it works again for all Apple devices! I made sure that I did not mess up with my other computers (PC), so I tested my wife’s laptop : successful!

    I hope this troubleshooting process will help you to fix your issue too!

    Enjoy!!! :)

    *** Sorry this post should have not been in this thread but I do not know how to relocate it !!! :) ***
     

    Attached Files:

  2. sleadrider macrumors newbie

    Joined:
    Nov 3, 2013
    #2
    It Worked

    I did exactly what you described and -- Success -- thank you so much -- I have done without printing on iPhone since iOS 4 upgrade broke me.. thank you so much for taking the time to share your experience..
     
  3. zizi rider thread starter macrumors newbie

    Joined:
    Oct 24, 2013
    #3
    :):):):) You are very welcome sleadrider! Glad it helped you out! :):):)
     
  4. dgorczyca macrumors newbie

    Joined:
    Nov 21, 2013
    #4
    Thank you!!!

    I followed your instructions and step 3 got me there. I had a minor issue with allowing AirPrint through Norton Security, but just did a program exception and it was all fine.

    Thanks again
     
  5. zizi rider thread starter macrumors newbie

    Joined:
    Oct 24, 2013
    #5
    Excellent news ! Another happy face !!! :)

    As I said there might be slight difference about the setup for each of us but this guide apparently helps quite a lot ! I am very glad it works for other users.
     
  6. Håkan Carlström macrumors newbie

    Joined:
    Nov 23, 2013
    #6
    Sulution for IOS 7-devices (?)

    Hi.



    At last I made AirPrint work with IOS 7-devices.

    I'm using Windows XP and a Dlink Router 605L




    • Follow the instructions on http://www.airprintactivation.com/
    • Activate "Sharing" for your printer
    • Add an exception for C:\Program Files\AirPrint\airprint.exe in the Windows-firewall.
    • Add an "Application rules" for port 6631 in your router.
    • You may have to supply your user- or admin password the first time you are printing to your printer.

    I hope this will help others.



    Yours Håkan Carlström

    purpletechnician.se
     
  7. Håkan Carlström macrumors newbie

    Joined:
    Nov 23, 2013
    #7
    Hi.


    At last I made AirPrint work with IOS 7-devices after Upgrading from Win XP to Win 7 Ultimate.

    I'm using a Dlink Router 605L

    I used all of my above settings and this:
    • Open port 631 in Router


    Yours Håkan Carlström

    purpletechnician.se
     

Share This Page