Windows Users: How to Jailbreak 2.1 if you haven't previously jailbroken

Discussion in 'Jailbreaks and iOS Hacks' started by RobLikesBrunch, Sep 15, 2008.

  1. RobLikesBrunch macrumors regular

    Aug 1, 2008
    If you have a jailbroken iPhone, you can simply restore using costom firmware. If you don't have a jailbroken won't be so lucky. So after trying over and over...I finally figured out a solution.

    Follow these steps, taken from:

    Written by TtOrMaMnY (thanks a lot dude, you helped me quite a bit)

    Now, in that thread, he tells us to uninstall and install the Mobileinstalltion thing...however it didn't work for me, and my iPhone got stuck at the Apple's a more "fail-safe" way to go about doing it:

    Once you've jailbroken you iphone, but you can't see installer or cyndia, download the 2.1 custom firmware (you should be able to find a link here:

    Uninstall iTunes 7.7 and Reinstall iTunes 8. Now sync your iPhone with iTunes, and shift +click on Restore and select the custom firmware. You won't get the Error (6) anymore and it will work.

    That's it... :D
  2. sye46 macrumors member

    Jul 21, 2008
    i didn't have to uninstall itunes 8 and downgrade to 7.7. i went straight to quickpwn and jailbroke my iphone 3G without any problems.

    make sure you uncheck the boot logo on quickpwn, because if you leave it checked, you will have a blank boot screen.
  3. RobLikesBrunch thread starter macrumors regular

    Aug 1, 2008
    Even better :D
  4. DravenGSX macrumors 6502a

    Aug 20, 2008
    The original method worked for me. There is one important step though which is to delete the MobileInstallation cache before rebooting. After you replace the MobileInstallation.Framework, go to /private/var/mobile/Library/Caches/ in TotalCommander and delete

    Voila, apps not installed via iTunes will now be visible.

    Happy hacking.
  5. RobT macrumors 6502a


    Dec 20, 2007
    Ohio, USA
    This worked perfectly, thanks!

    After a weekend of trying to get this to work, this method was the one...thanks again!
  6. sublyme2 macrumors newbie

    Jul 11, 2008

    Same here, finally it worked! thanks to OP

Share This Page