Windows with bootcamp disables "Tap to click" in OS X?

Discussion in 'macOS' started by mmo, Nov 30, 2008.

  1. mmo macrumors member

    Joined:
    Nov 30, 2008
    #1
    I have just used Bootcamp to install Windows XP on my girlfriends new Macbook. It worked quite well but there seems to be one small problem.

    When the computer has been booted into Windows, then the next time OS X is started the "Tap to click" function is disabled. When I go into system settings to enable it, I see that the check-box next to "Tap to Click" is checked. So to make it work I have to remove the check-mark and the click it again - then it is enabled again.
    How can Windows cause this? It has me a little worried that it can have such an effect. To my knowledge the two systems should be COMPLETELY isolated from each other so the only answer must be that Windows actually changes some setting inside the trackpad that is remembered during boot. That is, a setting in the actual firmware or something?
    Anyone know if this is right and if something can be done to fix it?
     
  2. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #2
    Try resetting PRAM and the SMC. These contain some data for the trackpad settings. It is likely something has got corrupt.
     
  3. mmo thread starter macrumors member

    Joined:
    Nov 30, 2008
    #3
    Hm, but the problem only occurs if the computer has been booted into Windows. It does not happen if it was in OS X before it was shut down.

    Do you think something has been corrupted that is only triggered when the computer has been in Windows?
     
  4. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #4
    never heard of that occurring. i have experienced clock changes, i.e. the once I boot into the other OS the clock is totally whack. Windows - OS X or the other way around all yield the same result. The clock is always reset.

    However, maybe you could try the PRAM/SMC resets and then a reinstall of the Boot Camp drivers.
     
  5. Timur macrumors 6502a

    Timur

    Joined:
    Oct 14, 2008
    #5
    I just experienced the same issue. But only after the first time I booted into OS X after running Vista bootcamped. Same happening as with original poster, the one-finger click was deactivated eventhough it was set as activated via Settings. I disabled and reenabled it to make it work again.

    Then I booted into Vista again to see if it happens again after switching, but it does not! So for me it only happened once yet. I will report it to Apple to let them know and just expect it wont happen anymore.
     
  6. Tex-Twil macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #6
    I have the same issue and it's everytime I reboot from Bootcamp to OSX. What's funny is that the tap to click works just after the boot (some seconds) then stops working.

    The rest of the time, no problem.
     
  7. siri macrumors newbie

    Joined:
    Jan 26, 2009
    #7
    I'm experiencing the same issue, even when I use Parallels with Windows running from BootCamp installation. It's not a big deal, but it's pretty annoying. Still no solutions? What about PRAM/SMC resseting, is it working? Thanks.
     
  8. alumac macrumors member

    Joined:
    Mar 31, 2009

Share This Page