Windows Won't Boot

Discussion in 'Windows, Linux & Others on the Mac' started by spyker3292, Nov 11, 2008.

  1. spyker3292 macrumors 65816

    Joined:
    Jul 7, 2005
    Location:
    Michigan
    #1
    Ok, I just downloaded the Left 4 Dead demo on Steam using Parallels. Once the demo finished downloading I shut down windows. The shut down took a really long time, and then Parallels just crashed. Tried to restart my computer and boot into my XP partition and I got the following error

    So I'm guessing that when Parallels crashed it screwed up my boot camp partition, and now this file is corrupt. I hope there aren't more files too... Anyway, how can I fix this without reinstalling? (I've got the windows CD)

    What? Wasn't expecting this to work. Parallels boots my boot camp drive, boot camp won't boot it.

    NEVERMIND: After restarting about 10 times it worked again. That was random... Really freaked me out :p.
     
  2. JDRick macrumors newbie

    Joined:
    Nov 14, 2008
    #2
    Having same boot error message <Windows root>\system32\hal.dll.

    I just came upon your post, and I am trying to help a friedn who has a mac-mini (used in his dental office) that is showing the same problem on booting... but I cannot get it to go away (more than 10 boots)... did you do something else to make it disappear?

    I am not a Mac expert, but somewhat familiar with Windows.... any suggestions on how to remedy this?

    Thanks for your help!

    Rick
     
  3. JNB macrumors 604

    JNB

    Joined:
    Oct 7, 2004
    Location:
    In a Hell predominately of my own making
    #3
    With Boot Camped or VM'd installs, the hal.dll error is usually related to the boot.ini file. When Windows is installed under Boot Camp, the assumption is that all paths are left as default and exampled by Apple. Any variation to that will prevent booting because the path specified in boot.ini doesn't exist because of the changes, and has to be manually edited.

    Good step-by-step
     
  4. JDRick macrumors newbie

    Joined:
    Nov 14, 2008
    #4
    Similar issue... Windows error on Mini-Mac

    I am trying to help a friend who's dental office uses this mini-Mac running windows xp. When booting, the missing or corrupt "....hal.dll" error.... so I tried rebooting with XP startup disk installed... nothing, then I thought maybe if I boot with the mac partition, I could work on it from there, but after clicking on the Mac icon instead of the windows icon when I started, it sat at the Apple logo with a spinning circle under it for quite awhil, and never installed the Mac software either...

    Any suggestions on how to attack why this computer isn't booting in either OS?

    Thanks!

    Rick
     

Share This Page