Windows won't read formatted FAT 32 external hard drive

Discussion in 'Mac Basics and Help' started by ayeplussjr, Jan 16, 2009.

  1. ayeplussjr macrumors regular

    Joined:
    Dec 29, 2008
    #1
    My post was not answered on someone elses's thread so I thought I would create another one. I originally had my external hard drive formatted to NTFS, but found out that it would not read on my iMac, so I formatted my external through disk utility to MS-DOS (FAT 32). My iMac is recognizing the external hard drive, but my windows computer is not. I want to transfer some files from my Windows PC to my iMac using my external hard drive, but windows just won't recognize hard drive now that it is formatted to FAT 32. Any suggestions on what I may be doing wrong?

    Thanks for the help!!!
     
  2. djchristie macrumors member

    djchristie

    Joined:
    May 25, 2006
    Location:
    Falkland Islands
    #2
    Hi there,

    I've had this exact issue, and I think it is to do with the Partition Map Scheme. If you open Disk Utility and select the external disk, you'll see at the bottom of the window all the disk info - I'd bet it's either GUID Partition Table or Apple Partition Map. You need it to be Master Boot Record.

    Select the Partition tab at the top of the window, then select 1 partition from the dropdown list. Then click the Options button underneath the partition window. You get 3 options, GUID, Apple and Master Boot Record. Select the latter, and hit ok. You'll then need to hit Apply, which will reformat the disk, so make sure you have anything on there copied beforehand. Then you'll be good to go!

    Hope that helps,

    Darren
     
  3. ayeplussjr thread starter macrumors regular

    Joined:
    Dec 29, 2008
    #3
    Hey....thanks for the tip. That worked out perfectly.....Thanks Again!!!!
     
  4. bmbosse macrumors newbie

    Joined:
    May 21, 2013
    #4
    Thank you!!! A client gave me a hard drive with some work on it and I couldn't figure out why after I moved everything off and re-formatted it, I still couldn't read it. It was giving me fits!!
     

Share This Page