Windows XP cd copies files but won't install

Discussion in 'Windows, Linux & Others on the Mac' started by fishenelmar, Mar 28, 2011.

  1. fishenelmar macrumors newbie

    Joined:
    Mar 28, 2011
    #1
    Hello, I really need help installing Windows XP SP2 please...

    I made a 20 GB partition using the latest Bootcamp version, then inserted the CD.

    The computer restarts, black screen, then blue screen. this is where i'm stuck, ive tried formatting on ntfs & fat (quick and full) and then the files get copied in the partition and that's as far as i get. when it restarts it shows me the same black screen / blue screen thing instead of doing the install...

    I've tried booting the windows partition (pressing alt as soon as i turn the macbook on) and it shows a folder with a question mark.

    Now, this is not the first time i face this problem. i once managed to install windows with the same CD on this same macbook, i just can't remember how i did it... but i remember the key was in how i formatted the partition...

    I'm going crazy, thanks.
     
  2. AshMan macrumors regular

    Joined:
    May 1, 2010
    #2
    Which version of windows 7 are you trying to install: 32 bit or 64 bit?

    I did have similar issues with booting to install windows 7 64 as far as I remember, would hang at boot, so I just installed the 32 bit version.

    There is probably a workaround for installing 64bit windows on it you probably need to search.
     
  3. fishenelmar thread starter macrumors newbie

    Joined:
    Mar 28, 2011
    #3
    Finally

    Thanks for replying AshMan, I'm not trying to install Windows 7, it's Windows XP SP2.

    Now, this morning I managed to install it… started from the beginning turning my disk into a single MacOSX partition again. I did the whole steps again partitioning the disk with Bootcamp and restarting with the Windows CD. Then i got to the blue screen asking me which partition i wanted to use. This time I deleted the bootcamp partition and the 200 MB partition too (though i've read in many forums this last partition should NOT be deleted, it's the only way that actually worked for me). So now i had the Mac OSX, an 8 MB un partitioned space, the 200 MB partition i deleted, and the -no longer- bootcamp partition which i deleted too.

    I formatted using FAT 32 (not the quick one) and files copied as many times before… and the MacBook restarted: I had never been so happy to see the Windows logo and the loading bar; the installation finished successfully.

    Once in Windows, I removed the Windows CD and installed the BootCamp drivers from my MacOSX Installation Disk and the MacBook restarted after the process.

    I pressed alt while the MacBook was turning on and ejected the CD, then clicked on the Windows partition… a blinking folder with a question mark appeared.

    I turned the MacBook off manually, pressed alt again and inserted the Windows CD and booted from it. Windows started loading and this is the ONLY way i can boot Windows.

    I've read in many forums this could be a problem with the boot.ini file in the windows partition root. Any ideas how i can fix it?
     
  4. Madman12 macrumors newbie

    Joined:
    Mar 11, 2011

Share This Page