WindowServer eating up CPU

Discussion in 'iMac' started by 11800506, Sep 13, 2008.

  1. 11800506 macrumors 65816

    11800506

    Joined:
    Oct 31, 2007
    Location:
    Washington D.C. Area
    #1
    I have an eMac 1.25 ghz with 2 gb of ram running Leopard and recently the process windowserver has been eating up large amounts of my CPU (often 60%+). I know that this process is essential to running my mac because it handles the GUI but I have searched on this topic and found no definitive answer on how to fix the issue. Some old threads suggested to delete some widgets or disable spaces but I have tried both yet the problem persists. Does anyone know what I can do to get it to stop using so much of my CPU?
     
  2. 11800506 thread starter macrumors 65816

    11800506

    Joined:
    Oct 31, 2007
    Location:
    Washington D.C. Area
    #2
    Does anyone know? This is really affecting the usability of my computer as now it slows down quite a bit just running Safari.
     
  3. Berlepsch macrumors 6502

    Berlepsch

    Joined:
    Oct 22, 2007
    #3
    I think we need more input to try and help you. Some of the questions that come to my mind:

    • Did you install any new apps or updates recently?
    • How is your memory usage?
    • Do you note a lot of hard drive access (i.e. swapping)?
    • Have you checked the system logs for error reports?
     
  4. 11800506 thread starter macrumors 65816

    11800506

    Joined:
    Oct 31, 2007
    Location:
    Washington D.C. Area
    #4
    Thanks for the initiative to help but I figured out what the issue was. It was a combination of switching my desktop every 5 seconds and running a time machine backup for the first time, but thanks anyways.
     

Share This Page