Wine 1.4

Discussion in 'Mac and PC Games' started by savvos, Mar 20, 2012.

  1. savvos macrumors regular

    Joined:
    Sep 8, 2007
    #1
    A new stable version of Wine (version 1.4) came out earlier this month. Is anyone hosting compiled Mac binaries for this version yet?
     
  2. Blakeasd macrumors 6502a

    Joined:
    Dec 29, 2009
    #2
    It isn't that hard to compile it yourself, just grab the Wine 1.4 source and follow these instructions.
     
  3. ScottishCaptain macrumors 6502a

    Joined:
    Oct 4, 2008
    #3
    Actually it kinda is.

    You cannot build WINE through Xcode 4.2 or later. This is because Apple dropped support for GCC in 4.2, and your only option now is the LLVM-GCC compiler which seems to ignore several important compiler flags (they're there, they just don't do anything).

    The end result is that any WINE compiled with Xcode 4.2 or later will immediately crash with an unhandled exception code. You cannot run anything, the resulting binaries are broken.

    You will need to compile WINE with either: A) an Xcode version lower then 4.2, or B) a custom GCC compiler- probably something from Fink or Macports or something like that.

    -SC
     
  4. MurderousMoppet macrumors newbie

    Joined:
    Jan 24, 2012
    #4
    the latest stable release of wine is 1.5 not 1.4. maybe this release fixes the xcode compile problems mentioned?

    you dont need to monkey with old versions of xcode to get GCC 4.2 either.
     
  5. cluthz macrumors 68040

    cluthz

    Joined:
    Jun 15, 2004
    Location:
    Norway
    #5
    All 1.5.x releases are development releases, 1.4 is latest stable.

    If you plan to run wine on OSX I suggest using Wineskin from www.doh123.com.
    It has downloader for all recent wine and crossover binaries.
    (from like 1.1.x to 1.5 including crossover 8 to 11.)
     
  6. thundersteele macrumors 68030

    Joined:
    Oct 19, 2011
    Location:
    Switzerland
    #6
    http://www.playonmac.com/en/news.html



    Concerning gcc, I use OSX gcc packages from here:

    http://r.research.att.com/tools/

    They have gcc packages for xcode 4.2, I hope they also work for 4.3.
    The apple llvm compiler is not fully compatible with code written for gcc. I highly doubt that there will be any fix from wine, since it is written for gcc.
     
  7. MurderousMoppet macrumors newbie

    Joined:
    Jan 24, 2012
    #7
    I meant to imply that perhaps 1.5 will compile using Xcode 4.2.
     
  8. doh123 macrumors 65816

    Joined:
    Dec 28, 2009
    #8
    As long as you do not want a Customized/patched Wine source... they stock Wine builds are already built and available for Wineskin, along with Crossover Wine versions too. There are also 3rd party customized engines available elsewhere for it (like at Portingteam.com).

    I haven't had access to my build machine for a week, but I'll have a Wine 1.5 version up later today.
     

Share This Page