Wine caused .app files to not load.

Discussion in 'macOS' started by uneasyE, Apr 27, 2018.

  1. uneasyE macrumors newbie

    Joined:
    Apr 27, 2018
    #1
    Starts very simple.

    Mac Version of a game (basic .app file)
    Either saying The application * can’t be opened or it bounces in the dock and disappears immediately.

    This started on El Capitan.
    I tried to use Wine to run the windows version of the previously mentioned game using all the information found here.

    Winehq.org

    It never worked no matter what I did,
    I tried all different versions and other similar applications (PlayOnMac etc.)
    I tried digging deep and figuring out why my wine would not run my .exe so I went on the WineHq forums and started using the terminal commands I found from people with similar problems.
    Again this did nothing.

    I am normally very knowledgeable when it comes to computers but after a certain point I was in over my head and did something that reoccurs no matter what.

    After giving up on trying to run an .exe
    I went to start the Mac .app version of the game ( wanted two installs for two versions one of which is windows only )
    Only to find that it won’t open.
    “The application * can’t be opened.”
    Or it bounces in the dock for a split second and disappears.



    I have tried everything.. redownloading the game, disk repairs, double checking and fixing permissions,
    Updating my current version of OS and trying to open it, then updating to Sierra, then wiping my hard disk and trying again. I’ve tried every troubleshooting tip on the subject also. It STILL happens. I’m currently reinstalling Sierra for the second time hoping it works..


    Any one have any advice?
    I’d really appreciate the help, this is such a complex problem that I’m worried it can’t be fixed..
     
  2. boast macrumors 65816

    boast

    Joined:
    Nov 12, 2007
    Location:
    Phoenix, USA
    #2
    Maybe the Console logs can give you clues into why it is failing.
     
  3. uneasyE thread starter macrumors newbie

    Joined:
    Apr 27, 2018
    #3
    Checked everything.
    It said something along the lines of can’t open do to weird reason error 13.
    I opened terminal and opened the package contents of the .app file and turned the file in the macOS folder back to executable.
    It worked for a moment then the game simply closed with no error report.
    I reinstalled OS entirely again and left it at 10.8.5 with no updates at all and it worked.
    But now my computer is slow to wake up, login etc. and I have no idea why...

    I can play my game now but I fear my computer may be damaged.
     

Share This Page