Winscp no Theme's folder???

Discussion in 'Jailbreaks and iOS Hacks' started by yomnym, Oct 14, 2009.

  1. yomnym macrumors 6502

    yomnym

    Joined:
    Sep 25, 2008
    #1
    Can install themes manually because there isn't a theme folder created, i get an error every time i try and access it. Any idea
     
  2. scirica macrumors 68020

    scirica

    Joined:
    May 13, 2008
    Location:
    Dallas, TX
    #2
    You searched in /root/library/themes and didn't see any theme folders? Mine are there in 3.1.2 pwned.
     
  3. foob macrumors 6502

    foob

    Joined:
    Feb 17, 2009
  4. yomnym thread starter macrumors 6502

    yomnym

    Joined:
    Sep 25, 2008
    #4
    Thanks for your replies.. The folder is there but when i double click on it to open it i get an error, i tried to drag and drop folders(themes) into it and it seems to work?? :confused: Kinda weird.. well i dont mind not being able to go into it, but what about to take them out? Thanks
     
  5. foob macrumors 6502

    foob

    Joined:
    Feb 17, 2009
    #5
    The themes folder requires root permission, I bet that's your problem. The root password is alpine, unless you have changed it, but I don't know how to use it with WinSCP.
     
  6. yomnym thread starter macrumors 6502

    yomnym

    Joined:
    Sep 25, 2008
    #6
    Yeah I know I have to enter the ip then root and then alpine and then change to scp down in the drop down box. I have root access but when I nsavigate to the folder and double click go open I get an error. I'll post exactly what it says tomorrow, thanks the help. Is there any other way to navigate into or through this folder besides iphonebrowser and wnscp? Thanks
     
  7. darngooddesign macrumors G3

    Joined:
    Jul 4, 2007
    Location:
    Atlanta, GA
    #7
    Have you tried setting the directory path inside that folder when you connect initially?
     
  8. yomnym thread starter macrumors 6502

    yomnym

    Joined:
    Sep 25, 2008
    #8
    can you explain in details how to do that please, its really bugging that i cant get into that folder as i use it a lot to deploy themes into it and also accessing is the only way to remove them. Thanks
     
  9. foob macrumors 6502

    foob

    Joined:
    Feb 17, 2009
    #9
    I usually use Discover to connect to the phone. It has an app store version which I assume is crippled, get the Cydia version. Discover opens a connection with the webdav protocol so you may need to install something on your computer if it's not built in to the system. Once it's working, you just connect by typing webdav://IPaddress:8080 into the address bar of explorer and you can drag and drop files just like it's a drive on the computer.
     
  10. yomnym thread starter macrumors 6502

    yomnym

    Joined:
    Sep 25, 2008
    #10
    Foob, can you help me out so i could use that app, i already installed it on my phone... i tried to go to the website they refer to but is down so i couldn't get more info on how to get it. What else do i need to do to transfer files or navigate through the phone.
     
  11. calvy macrumors 65816

    Joined:
    Sep 17, 2007
    #11
    If I were you, instead of installing all that crap on my phone, I'd download PuTTY, a windows SSH client. Use it to login as root/alpine (btw, you should change that password). browse to the Themes folder (cd /Library/Themes) and see what happens. If you can't get in, tell us what the error is, and do an ls -ld /Library/Themes and we can see if something is screwy.
     
  12. yomnym thread starter macrumors 6502

    yomnym

    Joined:
    Sep 25, 2008
    #12
    Putty is the same as Winscp? I rather because discover doesn't seem to allow me to navigate to the themes folder. Ill do some searching on putty. thanks for the recommendation. Where do i log in in putty, i opened it but didnt's see the log in, and how do i chage the password. Sorry im not too familiar with SSH apps.
     
  13. sev27 macrumors newbie

    Joined:
    Oct 15, 2009
    #13
    I have the same problem.

    I have a 3G I jailbroke with blackra1n the other day, and I can't seem to find the Themes folder. And all my searching on google did no good, every link I clicked about this referred to summerboard. :/

    If anyone could help me that would be great. :]

    EDIT: Found a way.

    http://www.hackthatphone.com/2x/themes_with_winterboard.html
     
  14. ODog4523 macrumors regular

    ODog4523

    Joined:
    Apr 11, 2009
    #14
    Thanks for the info...looks we had the same issue at the same time!

    I wonder why you have to take a different rout to get to the themes now...
     
  15. sev27 macrumors newbie

    Joined:
    Oct 15, 2009
    #15
    If you go to part 2 on that link I posted it tells you the correct directory. I don't remember it off the top of my head. >.<
     
  16. yomnym thread starter macrumors 6502

    yomnym

    Joined:
    Sep 25, 2008
    #16
    This is what i did and im not sure if the first step had anything to do with the fixing but here it is. Assuming you already had Winterboard
    1. Go into Winscp and delete the Theme folder, them create a new folder in the same place.
    2. Go to Cydia and uninstall Winterboard, this should delete it with any themes you had installed along with it
    3. In Cydia install "winterboard" only, not a theme and winterboard with it, just Winterboard.

    Then you should be able to go to Winscp and into your Themes folder.
     
  17. sev27 macrumors newbie

    Joined:
    Oct 15, 2009
    #17
    You shouldn't have to do that at all. That actually sounds like it could screw up your iPhone. o.0


    Just click on the link I posted, and go to page 2. I think the directory is /private/var/stash/Themes. It isn't in /root at all.
     
  18. yomnym thread starter macrumors 6502

    yomnym

    Joined:
    Sep 25, 2008
    #18
    Hopefully no one's phones get messed up, just posting what worked for me.
     

Share This Page