WinXP in VMWware - No Internet, HELP!

Michael73

macrumors 65816
Original poster
Feb 27, 2007
1,079
34
I swear this is the weirdest thing...

I'm using Fusion 3.0.2 to run WinXP SP3. Everything worked fine yesterday. This afternoon, I launched the VM and IE6 couldn't render any pages (neither would Safari for Win).

The network adapter is set up "Share the Macs network connection (NAT)" I keep getting a little note from the icon down in the tray that says "Limited or No Connection." I've tried everything I can think of: restarted the OS, shut down and restarted the VM. In the Lan Connection Status dialog box on the Support tab I've tried the Repair button. Nothing has helped.

On the Mac side, my connection is fine. I even have a MBP that's set up identically with my MP and the IE connection on it is having no issues.

What's going on and how can I get my LAN connection working again?
 

lavrishevo

macrumors 68000
Jan 9, 2007
1,846
188
NJ
I swear this is the weirdest thing...

I'm using Fusion 3.0.2 to run WinXP SP3. Everything worked fine yesterday. This afternoon, I launched the VM and IE6 couldn't render any pages (neither would Safari for Win).

The network adapter is set up "Share the Macs network connection (NAT)" I keep getting a little note from the icon down in the tray that says "Limited or No Connection." I've tried everything I can think of: restarted the OS, shut down and restarted the VM. In the Lan Connection Status dialog box on the Support tab I've tried the Repair button. Nothing has helped.

On the Mac side, my connection is fine. I even have a MBP that's set up identically with my MP and the IE connection on it is having no issues.

What's going on and how can I get my LAN connection working again?


Are you pulling an IP in windows?

Go to the command prompt in windows and type:

ipconfig

Start from there and if you are try to ping a website. Type:

ping www.apple.com

and see if you get any replies.

You can also try disabling and re-enabling the sharing of the internet connection.
 

Michael73

macrumors 65816
Original poster
Feb 27, 2007
1,079
34
When I go to the cmd prompt and type ipconfig I get the following:

Connection-specific DNS suffix:
Autoconfiguration IP suffix: 169.254.240.XXX
Subnet Mask: 255.255.X.X
Default Gateway: 169.254.240.XXX

BTW, my connection isn't hardwired. The connection is shared with my MP. I have an AT&T U-verse router set to bridge mode because the signal is being broadcast through a Time Capsule.

When I ping www.apple.com it doesn't even give me a connection timeout, it immediately returns the following message: Ping request could not find host www.apple.com. Please check the name and try again.

I've also gone into the control panel > network connections and disabled and re-enabled the LAN connection and it hasn't fixed the problem.
 

lavrishevo

macrumors 68000
Jan 9, 2007
1,846
188
NJ
If your still not working try in command prompt:

ipconfig /release (enter)

ipconfig /flushdns (enter)

ipconfig /renew (enter)

Maybe try resetting your router, don't think this will help though.

Also I forgot, with the ping command drop the www. just name.com or actual ip address.
 

lavrishevo

macrumors 68000
Jan 9, 2007
1,846
188
NJ
Also, have you added any firewall or anti virus between the times it stopped working?
 

Michael73

macrumors 65816
Original poster
Feb 27, 2007
1,079
34
If your still not working try in command prompt:

ipconfig /release (enter)

ipconfig /flushdns (enter)

ipconfig /renew (enter)

Maybe try resetting your router, don't think this will help though.

Also I forgot, with the ping command drop the www. just name.com or actual ip address.
OK, I tried flushing the DNS. What I got was this after trying to renew it:

Windows IP Configuration

An error occurred while renewing interface Local Area Connection : unable to contact your DHCP server. Request has timed out.

Also, have you added any firewall or anti virus between the times it stopped working?
Nope :(

Any more ideas?
 

JNB

macrumors 604
Try altering your VM networking settings to Bridged Mode, see if it passes the Mac's IP to the VM session. If that's successful, go back to NAT and check again.

I'm not sure if deleting the plist for Fusion would address this.
 

Michael73

macrumors 65816
Original poster
Feb 27, 2007
1,079
34
Try altering your VM networking settings to Bridged Mode, see if it passes the Mac's IP to the VM session. If that's successful, go back to NAT and check again.

I'm not sure if deleting the plist for Fusion would address this.
Well the good news is that changing the network adapter setting to "Bridged (Autodetect)" restored my network connection.

However, after changing the setting back to NAT, I once again lost my connection.

What does this tell me? Can I just keep it in bridged mode? Will this somehow result in a slower connection? Is there something I can do to restore the NAT connection?
 

acurafan

macrumors 6502a
Sep 16, 2008
615
0
are your vm dhcp server services started so that you can get an ip addr using NAT mode?

bring up Terminal, then type in ifconfig - are you seeing anything for vmnet1 and vmnet 8?? any vmnet entries showing?
 

Michael73

macrumors 65816
Original poster
Feb 27, 2007
1,079
34
are your vm dhcp server services started so that you can get an ip addr using NAT mode?

bring up Terminal, then type in ifconfig - are you seeing anything for vmnet1 and vmnet 8?? any vmnet entries showing?
Where could I check to see if my vm dhcp server services are started?

I changed my network adapter back to NAT and typed ipconfig and see nothing for vmnet1 or vmnet8. In fact, there's no entry after "Connection-specific DNS suffix:"