[WIP] Fedora 25 Server on Powermac G5

Discussion in 'PowerPC Macs' started by Lastic, Jul 1, 2017.

  1. Lastic, Jul 1, 2017
    Last edited: Jul 3, 2017

    Lastic macrumors 6502a

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #1
    So my first day of the challenge has been a fruitfull one.

    Inspired by this thread by the Amiga PPC guys

    http://forum.hyperion-entertainment.biz/viewtopic.php?f=35&t=3524

    , I decided to give this a try and succeeded after 9 hours of trial and error.

    First I would like to state that I only installed Fedora 25 Server on my G5 and have no idea how to dual-boot.
    Second I could not SSH into my system so I typed all instructions in manually whilst reading them from another screen.
    Third this procedure is not for the faint-hearted , nothing will explode but you have to dedicate some time to complete it.

    This is the procedure that I followed :

    http://linuxhacker.ru/d/?q=node/360

    Some things upfront which I had to do differently.
    1. The author had a non-working DVD , mine works so I burned the CD-ISO and booted from CD.
      I got the Fedora 25 Server netinstall iso from a Dutch mirror here :

      http://ftp.nluug.nl/os/Linux/distr/...64/iso/Fedora-Server-netinst-ppc64-25-1.2.iso
    2. As soon as the installer starts (graphical screen with Language choice) , press
      Ctrl+Alt+Fn+F2 , you will have a command-shell and type : modprobe i2c-powermac

      Then press Ctrl+Alt+Fn+F6 to return to the graphical installation screen

      This will avoid that the fans start spinning up and creating a jet-plane sound , I only figured this out after 2 hours of planes taking off in my living-room.
    3. I could not like the author start SSH or VNC so I couldn't copy paste his config, I read it from another screen and typed it over manually.
    4. The author chose manual partitioning , I didn't , I chose Automatic partitioning
    5. The author chose a Minimal install , this doesn't exist in Fedora 25, Fedora 25 Server is a text based server install
    My adapted procedure :

    So I chose my language, selected Automatic partition, waited for the mirror to be found and then clicked on Begin installation .
    You will be at a screen where you can set the root password , don't, just wait for the yaboot error .

    Press Ctrl+Alt+Fn+F2 and go to a shell.
    Now follow the procedure , here is my version :

    mkdir /etc/yum.repos.d
    cat <<EOF >/etc/yum.repos.d/fedora.repo
    [fedora]
    name=Fedora 25 - ppc64
    failovermethod=priority
    baseurl=http://ftp.nluug.nl/os/Linux/distr/fedora-secondary/releases/25/Server/ppc64/os/
    enabled=1
    #metadata_expire=7d
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-ppc64
    skip_if_unavailable=False
    EOF

    dnf --releasever=25 --nogpgcheck --installroot /mnt/sysimage/ groupinstall -y 'Fedora Server Edition'

    chroot /mnt/sysimage
    dnf clean all
    dnf install -y kernel grub2 hfsutils lvm2

    cat > /etc/default/grub <<EOF
    GRUB_TIMEOUT=5
    GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
    GRUB_DEFAULT=saved
    GRUB_DISABLE_SUBMENU=true
    GRUB_TERMINAL_OUTPUT="console"
    GRUB_CMDLINE_LINUX="rd.lvm.lv=powermac_ssd/swap rd.lvm.lv=powermac_ssd/root $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) nomodeset"
    The smiley has to be a colon and a round bracket off course
    nomodeset doesn't work with my Radeon videocard

    GRUB_DISABLE_RECOVERY="true"
    EOF

    grub2-mkconfig >/etc/grub2.cfg

    cat >/tmp/grub_modules <<EOF
    moddep.lst bitmap.mod datehook.mod gzio.mod lsmmap.mod all_video.mod reboot.mod terminal.mod bitmap_scale.mod datetime.mod halt.mod memdisk.mod regexp.mod test.mod blocklist.mod echo.mod help.mod memrw.mod relocator.mod trig.mod boot.mod elf.mod hexdump.mod minicmd.mod scsi.mod true.mod bufio.mod ext2.mod hfs.mod msdospart.mod search.mod video.mod cat.mod fat.mod hfsplus.mod normal.mod search_fs_file.mod video_fb.mod cmp.mod font.mod ieee1275_fb.mod part_apple.mod search_fs_uuid.mod videoinfo.mod configfile.mod fshelp.mod linux.mod part_msdos.mod search_label.mod cpio.mod gettext.mod loadenv.mod parttool.mod setjmp.mod crypto.mod gfxmenu.mod loopback.mod probe.mod sleep.mod date.mod gfxterm.mod ls.mod read.mod suspend.mod kernel.img
    EOF

    mkdir /tmp/grub-modules
    cd /tmp/grub-modules
    for i in `cat /tmp/grub_modules` ; do cp /usr/lib/grub/powerpc-ieee1275/$i . ; done

    I did blkid /dev/sda3 to get the UUID needed hereunder

    cat > ../grub.cfg <<EOF
    search --no-floppy --fs-uuid --set=root a732e5bd-e4a8-4ffb-a0fe-f49fca582cc4
    set prefix=($root)/grub2
    configfile /grub2/grub.cfg
    EOF

    grub2-mkimage -c ../grub.cfg -p /grub2 -O powerpc-ieee1275 -o ../grub.img *.mod

    Set your root password using passwd

    # Fan control fixup
    cat >/etc/modprobe.d/windfarm_powermac.conf <<EOF
    # For Powermac11,2 but likely for any kind of windfarm modules
    install windfarm_pm112 /sbin/modprobe i2c_powermac ; /sbin/modprobe --ignore-install windfarm_pm112

    dnf update

    Then reboot into Open Firmware using Cmd+Option+O+F

    I followed these instructions
    https://github.com/masterzorag/G5_ppc64-linux

    but I had to do boot hd:,grub.img

    Now GRUB2 will start and then your Fedora 25 Server will start and you have a console.

    For some reason , the Server version needs IPv6, I tried to disable it but haven't succeeded yet thus so far it's Ethernet cable is plugged in directly to my ISP modem since they provide IPv6 addresses already.
    Otherwise it will stay stuck during boot at IPv6 ADDRESREQUEST


    dnf grouplist will show you all DesktopManagers that you can install , I installed Mate via

    (dnf groupinstall "MATE Desktop")

    {3-JUL-2017}
    what worked for me is dnf group install mate-desktop
    then echo "exec /usr/bin/mate-session" >>~./xinitrc
    First time you can start it with startx after a reboot lightdm will start automatically.
     
  2. Lastic, Jul 1, 2017
    Last edited: Jul 3, 2017

    Lastic thread starter macrumors 6502a

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #2
    So I'm guessing it doesn't like my video-card.

    I tried Mate, Cinnamon and then LXDE.

    LXDE starts but the colors are weird.

    In this screenshot Terminal looks OK but on the real screen it's unreadable.

    Unfortunately switching from a Radeon to Nvidia didn't help.

    LXDE.png
     
  3. Lastic, Jul 3, 2017
    Last edited: Jul 3, 2017

    Lastic thread starter macrumors 6502a

    Joined:
    Mar 19, 2016
    Location:
    North of the HellHole
    #3
    Day 3 of the challenge

    Having a better previous Ubuntu experience with my Radeon videocard, I installed that one again.

    I thought of erasing this install and using the image from the Hyperion Forum but I realized they used a manual yaboot
    whereas mine uses GRUB2 as by the procedure posted in the 1st post.

    I uninstalled all DesktopManagers,reinstalled mate-desktop , booted GRUB without the nomodeset option and I got Mate to start.

    This screenshot is accurate, the colors you see here is what I get on my screen

    Fedora 25 Server Mate 3jul2017.png

    But video is super slow so it looks like the CPU is doing everything not the GPU, colors are still off a bit but at least now I can do things in GUI.

    So to be continued, next up check mesa, ColorDepths and hopefully get 2D (3D?) acceleration.
    Also correct the IPv6 needed issue and figure out how the Server version can have all the Workstation repositories so I can install vlc and other desktop utilities.

    But so far happy with my progress in the past 3 days of thinkering.
     

Share This Page