Wired keyboard lag on TB display? (not solved!)

Discussion in 'Mac Accessories' started by iDemiurge, Sep 23, 2011.

  1. iDemiurge, Sep 23, 2011
    Last edited: Oct 8, 2011

    iDemiurge macrumors 6502

    iDemiurge

    Joined:
    Feb 7, 2011
    Location:
    Portugal
    #1
    Got my Thunderbolt Display yesterday and hooked it up to my 11" MBA. I'm using an apple wired keyboard and a logitech performance mouse.

    When the keyboard is connected to the display I experience significant input lag, with inputs sometimes being skipped altogether. I am currently using all the ports on my display except the thunderbolt output. The mouse receiver is unaffected, regardless of whether I plug it directly into the display or into one of the keyboard's USB ports.

    The lag disappears if I connect the keyboard directly to the MBA. Anyone else experiencing this or a similar issue?


    EDIT: The lag was somehow related to a virtual machine running WinXP. It would eventually return no matter where I plugged the keyboard. Sorry for the misleading thread.

    EDIT 2: My WinXP virtual machine seemed to be affecting the keyboard. But the USB ports on the Thunderbolt display DOES cause the keyboard to lag. After some time of use it begins to drop letters or to get stuck on a key.
     
  2. iDemiurge thread starter macrumors 6502

    iDemiurge

    Joined:
    Feb 7, 2011
    Location:
    Portugal
    #2
    I'm bumping this thread because what I thought was solved is indeed an issue. I stopped using the virtual machine and noticed that the issue disappears if the keyboard is connected to the MBA.

    I also used a wireless keyboard for a while, so the problem went unnoticed.

    The problem has been reported here:

    https://discussions.apple.com/thread/3339966?start=0&tstart=0

    And here:

    http://arstechnica.com/civis/viewtopic.php?f=19&t=1156446

    Anyone having the same issue? I wonder if I should make a complaint with Apple or wait for another firmware update.
     
  3. Lennyvalentin macrumors 6502a

    Lennyvalentin

    Joined:
    Apr 25, 2011
    #3
    Using Apple wired keyboard myself with my TBD, not noticed any lag whatsoever. Only connectors on the display I'm using right now is an iPhone charging cable (just dangling when not charging the phone) and a gigabit ethernet cable to a time capsule.

    Obviously the issue you're experiencing shouldn't occur, but since it does, have you tried disconnecting other devices from your display one by one or in combinations to see if it makes any difference?
     
  4. DaveOZ macrumors regular

    Joined:
    May 13, 2008
    #4
    Same issue here with MBAir 11 and TB display. Keystrokes missed and repeated at random. I have the latest firmware update on the display and reset PRAM and SMC. It seems to be working better reseting but I will be watching it closely this week.

    Also, when using a USB hard drive it hangs the computer while transferring large amounts of data (30gb).
     
  5. iDemiurge thread starter macrumors 6502

    iDemiurge

    Joined:
    Feb 7, 2011
    Location:
    Portugal
    #5
    I did transfer some large amounts of data, but through firewire. Did not experience any issue.

    Right now I have only a superdrive (idle most of the time) and the keyboard connected to the display. I removed the mouse receiver from the keyboard and connected it directly to the display to see if the problem disappears. No dice. It comes back just like before.

    I noticed however that the problem always begins by the keyboard ignoring a keystroke immediately after I have placed the cursor with the mouse somewhere. I wonder if it's related to the use of a third-party mouse. I'd be interested to know if anyone using apple's wired keyboard with either a BT magic mouse or magic trackpad is also having the same issue.

    I've just connected the mouse receiver to the MBA, leaving the keyboard on the display, and the issue again seems to have disappeared. I'll use it for a while and report back.
     
  6. iDemiurge, Oct 9, 2011
    Last edited: Oct 9, 2011

    iDemiurge thread starter macrumors 6502

    iDemiurge

    Joined:
    Feb 7, 2011
    Location:
    Portugal
    #6
    Update:

    I've run my computer the whole day today with the wired keyboard connected to the display and the receiver from my logitech mouse connected directly to my MBA.

    I did not experience any lagging or hanging on my keyboard. I have also typed while playing a dvd from a superdrive connected to the display and doing some backing up using the firewire port.

    Since the issue also does not manifest itself with both the keyboard and the receiver connected to the MBA (with the receiver connected through the keyboard), I can conclude that the issue is related to having two USB input devices connected to the display at the same time, either with both directly on the display, or with one of them connected to one of the USB ports on the keyboard.

    I have no clue what can cause this. Even though the issue is triggered by the mouse being connected as a second USB input device on the display, the mouse itself is in my case never affected.

    Solutions would be to leave the receiver on the MBA permanently. Or to get a magic trackpad. Sigh...
     

Share This Page