Wireless Adapter permanently disabled after sleep mode - Windows 7 64 bit

Discussion in 'Windows, Linux & Others on the Mac' started by chemnerd1, May 6, 2014.

  1. chemnerd1 macrumors newbie

    Joined:
    May 6, 2014
    #1
    Hello,

    Info:
    Laptop: 2014 Macbook Pro running Bootcamp (dual boot...not a VM) with Windows 7 Pro 64 bit
    OS: Windows 7 Pro 64 bit
    Network Adapter: Broadcom 802.11ac Network Adapter
    Driver version: 6.30.223.215

    Issue: My broadcom 802.11ac wireless adapter becomes permanently disabled when waking from sleep mode. It requires a restart in order to become enabled. If I try to manually re-enable it, I get a message saying "Enabling..." -> "Enabled!" but after this message the device still says Disabled and the wireless still won't connect to anything. This issue is very reproducible. Occurs both under battery power and when plugged in.

    What have I tried?: Tried disabling the "Allow windows to disable this device to save power" under power management, which didn't work. Tried updating driver but Windows Update says the driver is up to date. I was able to find a newer version (6.30.223.227) but I can only find it hosted on Russian websites which makes me a little suspicious.
     
  2. Henk Poley macrumors regular

    Joined:
    Sep 22, 2008
    #2
  3. chemnerd1 thread starter macrumors newbie

    Joined:
    May 6, 2014
    #3
    Hello Henk,

    I just got the laptop last week so everything is the latest version. Bootcamp version is 5.1 (I repaired using 5.1.5640 just to make sure). I also tried to uninstall the Broadcom Driver and re-install the latest bootcamp Broadcom driver but it didn't fix anything. What I did find is that if I choose hibernate instead of sleep then the Broadcom network adaptor will return, but ideally I would like to be able to use sleep so that the computer returns faster.

    I think my next course of action will be to start rolling back Broadcom drivers and see if an earlier version works better.
     
  4. chemnerd1 thread starter macrumors newbie

    Joined:
    May 6, 2014
    #4
    Does anyone know where I can download older driver versions for the Broadcom 802.11ac network adaptor?
     
  5. chemnerd1 thread starter macrumors newbie

    Joined:
    May 6, 2014
    #5
    OK so I just solved my problem. It turned out it was being caused by my Zone Alarm Pro Firewall. I re-booted into safe mode, uninstalled the firewall, restarted and now the network adaptor works fine coming out of sleep. I installed Comodo Firewall and the network adaptor is still working like it should.

    On a side note, I also use Avast Antivirus. I uninstalled that first (before the firewall) and the network adaptor was still not re-enabling so Avast was not an issue. I have since re-installed Avast with the Comodo firewall and everything is running fine.
     

Share This Page