Wireless Aluminum Keyboard with "S" key issue

Discussion in 'Mac Accessories' started by albeik, Aug 7, 2008.

  1. albeik macrumors regular

    albeik

    Joined:
    Jul 1, 2003
    #1
    Hi everyone,

    I just purchased a Wireless Keyboard (and mighty mouse) for my mac pro. The keyboard is excellent - the only issue I have with it is that the key "s" sometimes won't trigger until I press it couple of times. It doesn't matter if it was the first thing I press after a long wait. Typing a word like "Mississippi" may require pressing the "S" key 7-9 times to get all 4.

    I tried the search -- only found results related to the "first" key press may not get triggered which was fixed by a firmware release.

    Anyone experienced this issue before?

    PS: My wired Might Mouse worked perfectly on my black desk. The wireless version does not work (mouse cursor won't even move) so I had to resort to getting a mouse pad. Are the lasers and tracking devices that different between the two?

    Thanks for everyone's time.
     
  2. QCassidy352 macrumors G3

    QCassidy352

    Joined:
    Mar 20, 2003
    Location:
    Bay Area
    #2
    I have a wireless aluminum apple keyboard and it works great. I think you should take it back and ask for an exchange because that shouldn't be happening.
     
  3. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #3
    Yea, second that. Although all the Apple stuff I've purchased have no defects.
     
  4. albeik thread starter macrumors regular

    albeik

    Joined:
    Jul 1, 2003
    #4
    Thanks guys. I just got back from the Apple Store. In addition to upgrading to a 3G iPhone - the genius bar replaced my wireless keyboard and my iPhone headset (the left ear is loose).

    Excellent experience. Everything took less than 20 minutes. :)

    Thanks guys!
     

Share This Page