Wireless card is acting flaky

Discussion in 'MacBook Pro' started by Ender17, Nov 27, 2008.

  1. Ender17 macrumors regular

    Joined:
    Aug 3, 2005
    #1
    I have a MBP I got in August and lately I've noticed the wireless card keeps losing connection. If I turn Airport off and then reconnect, it works, but it's pretty annoying. Any ideas? Should I just take it in to the Apple store? Think they'll give me any trouble about replacing the hard drive myself?
     
  2. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #2
    I would have it fixed if it's a hardware issue, but did you diagnose your router, etc? I found I've been blaming my wireless card for while, but then I realized it was my router that was incompatible with my Mac.

    As with the replaced HDD, I wouldn't think they care, but I normally put the original back in, just in case.
     
  3. Ender17 thread starter macrumors regular

    Joined:
    Aug 3, 2005
    #3
    it happens at school, home and my parent's house
    I just found a site that recommended resetting the PRAM so I did that, will see how it works
     
  4. Ender17 thread starter macrumors regular

    Joined:
    Aug 3, 2005
  5. Beau10 macrumors 6502a

    Joined:
    Apr 6, 2008
    Location:
    Downtown San Diego
    #5
    Yeah, this is a well known issue. Threads with hundreds of responses on the Apple support forums.

    It could be possibly tied into the firmware update with 003/004, that's when I first noticed it.
     
  6. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #6
    A wireless card replacement may work then. The key is not to have Apple tell you what's wrong, but rather you tell the Genius what you need replaced.
     
  7. Hutch1 macrumors 6502a

    Hutch1

    Joined:
    Jul 24, 2008
    Location:
    Guelph, ON
    #7
    Just had mine fixed through Apple Tech support.

    The problem I had seems to be with realplayer down loader. Tech sadi they've had numerous issues with it screwing up internet connections.

    go to apple menu
    system preferences-accounts-login items- click on realplayer- click on minus sign, restart computer.

    good luck it fixed mine. Let me know if it works.
     
  8. Ender17 thread starter macrumors regular

    Joined:
    Aug 3, 2005
    #8
    don't have real player
    gonna try to make it to the genius bar tomorrow
     
  9. Azagar macrumors member

    Azagar

    Joined:
    Nov 29, 2008
    Location:
    San Francisco
    #9
    I had this exact problem, what I discovered is the current firmware of the wireless card does not like WPA encryption. I found this out because I went into my router and altered the WPA mode to WPA and WPA2 (Auto on my D-link). This fixed my never connecting to my network after resuming from sleep issue, and kept compatibility with older hardware that only supports WPA in my home. Ever since this fix I automatically connect to my network, I also have one more thing of advice if you're using the default airport profile set the wireless to top priority, by default it's set pretty low.
     
  10. Ender17 thread starter macrumors regular

    Joined:
    Aug 3, 2005
    #10
    it happens at school too on an unsecured wireless network
    as for priority, if I goto system prefs > network, on the left it has airport at the top and then bluetooth, ethernet, and something else
     
  11. Azagar macrumors member

    Azagar

    Joined:
    Nov 29, 2008
    Location:
    San Francisco
    #11
    Oh even on a unsecured network, then not sure I can help. On the priority you have to make sure it is on the top, just looking at the column it places which ever you are using at the top.
    Click on the icon next to the - icon then hit set service priority just to make sure.
     
  12. Ender17 thread starter macrumors regular

    Joined:
    Aug 3, 2005
    #12
    it was at the bottom
    put it at the top
    downloading a big file now to see if it stays connected
    hope this works
     
  13. Ender17 thread starter macrumors regular

    Joined:
    Aug 3, 2005
    #13
    well so far so good
    the file I tried downloading the other day at home completed without issue and I used it for about an hour at school today without any disconnects
    thanks!! :)
     
  14. mikes70mustang macrumors 68000

    mikes70mustang

    Joined:
    Nov 14, 2008
    Location:
    US
    #14
    Yah, ive noticed my airport range is poopy compared to my friends 2 year old mac book. If im over at her house she can snag a full signal from the neighbors. I can barely get a bar, usually none. I basically have to sit in the yard to get any signal. I just wonder if it has anything to do with MBP's being aluminum. Or if this is normal, or if i can do sumthin to change it.
     
  15. Ender17 thread starter macrumors regular

    Joined:
    Aug 3, 2005
    #15
    just a final update, using my notebook in class right now and it's working perfectly
    have not had a single disconnect since changing the priority
    thanks again
     
  16. Ender17 thread starter macrumors regular

    Joined:
    Aug 3, 2005
    #16
    well it's back :mad:
    still extremely intermittent
    I took it down to the genius bar and they did something that erased all my preferences, resetting the dock and background
    he also said I could try a archive and repair at home and if that didn't work, then it would be time to ship it off
     
  17. Beau10 macrumors 6502a

    Joined:
    Apr 6, 2008
    Location:
    Downtown San Diego
    #17
    Just wanted to note what Agazar said above (running an open network) has made things rock solid for a couple weeks now. And before I was having this issue like nobody's business.
     

Share This Page