Wireless connection DHCP problem?

Discussion in 'Mac Basics and Help' started by allan_zip, Apr 17, 2008.

  1. allan_zip macrumors regular

    allan_zip

    Joined:
    Feb 25, 2005
    Location:
    Belfast, N. Ireland
    #1
    Ok, here's the set-up:
    I have a MacBook 2GHz running 10.4.11 and a 14" iBook G4 1.42GHz running 10.4.11. We have virgin media broadband's basic package and a D-link DI-524 router. The macbook has no problems connecting to the wireless signal and all works great in every respect, no problems at all.
    The iBook on the other hand refuses to connect despite working briefly the other day when the broadband was first switched on. The DHCP now keeps coming back with a 169. IP address and the network status page shows the airport status flashing red and orange (I can see the dlink network in the menu bar but am not getting any 'bars')
    The system.log in Console on the iBook is reporting a message every 4 seconds that says:

    kernel[0]: AirPort: Link Active: "dlink" - 00195b00cc07 - chan 6
    kernel[0]: AirPort: Link DOWN (AP dis Assoc 0)

    Nothing was changed on the iBook to make it act this way. It works fine off the ethernet cable coming out of the router and I tried copying the settings from that and putting them in manually to the airport settings but no joy.
    Virgin say there is no problem with the signal and it is therefore a problem with my router configuration. They did the reboot thing, gobbled up all my phone credit and then said oh well that's all they could do.
    Anyone have a clue what might be wrong and better still, how to fix it?
    Hope someone can help.
    Thanks in advance.
    Allan
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Does that iBook have the older "AirPort" card in it, as opposed to the newer "AirPort Extreme" (and in the newer Intel Macs, "AirPort Extreme with 802.11n support")? If so, the problem appears to be an incompatibility between the card and the router settings. Is the router set to 802.11g only mode? If it is, try switching it to 802.11b/g mixed mode.
     
  3. allan_zip thread starter macrumors regular

    allan_zip

    Joined:
    Feb 25, 2005
    Location:
    Belfast, N. Ireland
    #3
    System profiler says Airport Extreme. Firmware 405.1
    I have tried the settings in the router for both mixed and 'g' neither work for the iBook. Should i leave it on mixed? It's currently on 'g'.
     
  4. allan_zip thread starter macrumors regular

    allan_zip

    Joined:
    Feb 25, 2005
    Location:
    Belfast, N. Ireland
    #4
    I've just checked in my router stats and i'm seeing a recuring message similar to the Console message. It says:
    Thursday April 17, 2008 12:49:12 Reassociated: 00-14-51-87-40-95 st=0
    Thursday April 17, 2008 12:49:15 Disassociated: 00-14-51-87-40-95 because WPA retey failed

    Is there a way to reset my security settings for the iBook that may sort this out?
     
  5. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #5
    Okay, that helps a lot. It appears that it is trying to connect via WPA and failing. Is your network set up to use WPA security (or WPA2)? If it is, make sure you have the right security option selected for that network in the iBook's network settings. If not, then deselect WPA - that's the problem.
     
  6. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #6
    Yes, you have to go into System Prefs -> network and select the Airport Card. Click the "Advanced" button, delete (use the "-") your existing network. Click OK. Now under "Network Name" choose "Join other network". Then click "Show Networks" and select your own. Then click "Join" and you should be prompted for a WPA password.
     
  7. allan_zip thread starter macrumors regular

    allan_zip

    Joined:
    Feb 25, 2005
    Location:
    Belfast, N. Ireland
    #7
    Thanks folks.

    I'd just tried something similar to that but it wouldn't work. I can't see any 'advanced' button on the Network settings either (you might be on Leopard).

    I've just reset the router to factory settings and everything's working on both machines. The network is open but i've set the filters to only allow our two MAC addresses onto the network (the router itself is password protected).
    Would anyone recommend this setup or should i go in and just reset all the passwords? I think there might have been some kind of conflict with the type of security I had originally selected. i was using WPA2 personnal and that wouldn't seem to work on the iBook. Still not entirely sure where I cocked up but it seems to be ok now.
     

Share This Page