Wireless connection is fine but Internet drops

Discussion in 'Mac mini' started by peck2000, Feb 19, 2011.

  1. peck2000 macrumors newbie

    Sep 22, 2006
    Here's a strange and vexing problem. My Mac Mini is connected to a Linksys (WAG354G) wireless network. Its Wireless connection is very stable and reliable. But weirdly, the Mac Mini has trouble maintaining an internet connection. The only way to get it back is to restart the Linksys and then the Mac Mini. this is a bit inconvenient if I just want to browse the web off the Mini.

    No other mac in the house has this problem. We have desktops (two G4s) and laptops (two MacBook Airs and a MacBook Pro) and none of them display this problem. So, I'm guessing it's not the Linksys that's at fault.

    Anyone else see this behaviour?
  2. Waragainstsleep macrumors regular

    Oct 15, 2003
    Does it have a self-assigned IP when it drops out?
    If so, try renaming your wireless network. This has fixed this issue a number of times for me recently.
  3. fa8362 macrumors 65816

    Jul 7, 2008
    Have you tried testing location? Some locations are better than others for wireless. Perhaps the Mini is just in a bad location.
  4. peck2000 thread starter macrumors newbie

    Sep 22, 2006
    Wireless connection is fine but Internet drops

    No, it picks up its IP number from the Linksys just fine. And it keeps the wireless connection fine. For example, I can access the Mini from my MacBook Pro with screensharing just fine ... even after the Mini looses its internet connection.

    Like I said, a strange problem ...
  5. peck2000 thread starter macrumors newbie

    Sep 22, 2006
    Wireless connection is fine but Internet drops

    That's not the issue. The Mini holds its wireless connection just fine. You can see it on the networks and it can see other computers. It's not loosing its wireless connection.

    But after a while, it can't access the internet. I don't think loosing the internet when it maintains its wireless connection is a location issue.

    Besides, the Mini is used as a media centre so it has to be near the tv in the living room.
  6. pappadu macrumors newbie

    Mar 1, 2011
    Setting up network locations seems to resolve this issue

    I had this same problem. It seems it was due to virtual 'parellels' adapters that are automatically activated. I created separate 'network locations' (in network preferences) for home where airport took preference over ethernet and the the two parallels adapters were deleted. It solved the problem. Good luck!
  7. bruceleeroy macrumors member

    Jun 14, 2009

    I am experiencing the same problem with my macbook pro. How do I delete the two parallel adapters?

Share This Page