Wireless connection slow - I am about to throw imac through the window

Discussion in 'Mac Basics and Help' started by nosnadn, Jun 24, 2008.

  1. nosnadn macrumors newbie

    Joined:
    Jun 24, 2008
    #1
    I have a big problem with my new iMac - it doesn't connect fast on my wireless network. Basically this manifests itself in slow internet browsing etc..

    My set up is

    - ADSL Modem
    - SMC Wireless N Router (this is the 3rd router I have tried so don't think it is this!)
    - No encription or security (I live in the middle of nowhere!)

    The wireless connection works fine on all my pcs and laptops

    iStumbler says the signal is 33% and noise is anywhere between 7-20%. The top bar has 5 bars.

    HELP!

    Nigel
     
  2. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    It's probably best to first test if the connection itself is working OK with your new iMac. What I would suggest you do to test it is to run a CAT-5 cable from the router to your iMac. If the connection is still slow, then the problem may be with your DNS or other ISP settings.

    If after connecting the CAT-5 cable your browsing speeds up and returns to normal, then you can assume something is not right with the airport settings.

    I had the same problem here with my connection (Verizon) and had to do the trouble shooting myself since the Verizon techs were not familiar with Macs. During the time I had difficulty, my Windows machine was OK. Drove me crazy for awhile until I discovered the DNS automatic settings provided by Verizon did not work for my MacBook even though the Win machine was not effected at all.

    Changing the DNS settings to OpenDNS resolved the problem.

    http://www.opendns.com/features/overview/

    Let us know what you discover and we can go from there.

    Regards.
     
  3. nosnadn thread starter macrumors newbie

    Joined:
    Jun 24, 2008
    #3
    Thanks for that - really helpful - how do i change the dns settings to open dns?
     
  4. sou1 so1di3r macrumors 6502a

    sou1 so1di3r

    Joined:
    Jun 26, 2008
    Location:
    Denver, CO
    #4

    Do you think DNS is my problem???

    http://forums.macrumors.com/showthread.php?t=506564
     
  5. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #5
    Visit that web link and click on "Get Started". It will guide you thru the process which is pretty easy.
     
  6. hermanocleas macrumors newbie

    Joined:
    Jul 1, 2008
    #6
    I experience the same issue...

    However, switching my DNS to point to Open DNS servers didn't resolve the issue for me. I also stopped using safari and started using Firefox which didn't seem to help either. I have tried two different wireless routers; an apple airport (smaller one) and a d-link DI-524 which is currently the one in use. I am using 128bit-WEP security as WPA is not supported as far as I can see in Leopard. Any other ideas on what to check.

    My wifes laptop runs fine. When I connect directly to the router via cat5 I'm fine. Thanks!!
     
  7. ElectricSheep macrumors 6502

    ElectricSheep

    Joined:
    Feb 18, 2004
    Location:
    Wilmington, DE
    #7
    If these numbers are correct, than that explains your poor wireless performance. Your iMac is spending a lot of time retransmitting packets, which is hurting your bandwidth.

    I would say that either the location you put your iMac in is filled with background noise, or the antenna connection to the Airport Card (or even the card itself) is faulty. While its not technically impossible for you to open up your iMac to check the antenna connection, its not something I would recommend unless you are comfortable working with electronics.
     
  8. agentphish macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #8
    WPA in all of its various flavors is CERTAINLY supported supported in Leopard.
    When you click on the Airport icon at the top of the screen, and then choose a network, and are prompted for a password simply put in your WPA password. Leopard is a bit smarter than Tiger and Panther in that you don't have to select the type of encryption the connection is using. It just knows. Good luck with that.

    As far as your iMac, is there any way you can take it someplace else to test it out? It sounds like the card is bad or there's a bunch of interference in the room where you have it. You can try changing the channel that the wireless broadcasts on in your router settings and that might help you as well. I know it did for my powerbook.
     

Share This Page