Wireless connectivity issue with mbp and ipod touch

Discussion in 'Mac OS X Server, Xserve, and Networking' started by kjsmith1026, Dec 28, 2008.

  1. kjsmith1026 macrumors newbie

    Joined:
    Dec 28, 2008
    #1
    I have a Macbook Pro (10.5.6) and an iPod Touch (2.2 firmware). When my mbp is connected to the network wirelessly, I cannot access network apps on my touch (touch apps are 1passwd, airshare, ping, ...). However, when the mbp is connected via a wired cable, I can access all the touch network applications just fine. I can access the touch over wireless from windows xp machines I have on the network and from other ipod touches on the network. The only problem is when the mbp is connected wirelessly that I can't access the ipod from the mbp. The touch has no problem with network connectivity to the internet or other devices on the network.

    To rule out my wireless access point, I created a wireless network directly on the mbp and had the touch connect to that and still I can't communicate between the mbp and the touch (the touch does receive an ip using dhcp). I had another touch connect to the same mbp wireless network and both touches can communicate with each other through the mbp wireless network, but neither can communicate directly to the mbp (e.g. can't ping the mbp).

    Does anyone have any ideas on what the problem could be? Thank you.
     
  2. x s macrumors newbie

    Joined:
    Dec 27, 2008
    #2
    When your mbp is connected to your wireless network, can it find the other WinXP machines, and can they ping your mbp? Just to make sure they're on the same subnet.

    When your touch connects to that same network, it should be able to ping all other machines on your network - except if you've got a firewall somewhere?
     
  3. kjsmith1026 thread starter macrumors newbie

    Joined:
    Dec 28, 2008
    #3
    When the mbp is wireless only, it can ping/access all other machines on the network (some of which are wired and some are wireless - all are windows based, the mbp is the only mac on the network). The ipod can ping/access all other devices on the network as well. The problem only occurs between the ipod touch (I've tried 2 of them and both exhibit the same behavior) and the mbp when it is connected via wireless.

    I've been doing some packet captures via wireshark and when initiating the ping from the ipod, I see arp requests come in from the ipod and the reply go out from the mbp, but nothing after that. When I initiate the ping from the mbp to the ipod, I see the arp request go out, but never get an arp reply.
     
  4. x s macrumors newbie

    Joined:
    Dec 27, 2008
    #4
    Just to make sure you're not confusing things: ARP is a L2-protocol, ping uses the L3 "ICMP" protocol.
    What you're describing looks strange (to me, at least :confused: ).
    When ping'ing from the iPod: Does your iPod actually send the ICMP-request? And does the mbp reply? If so, the ping should be succesful imo.

    Try running "arp -a" from both terminals (ipod+mbp), and paste the output here. And include your iPod's MAC-address too, together with your mbp's wifi-MAC-address, that might help me further. (I suspect there's a problem with the ARP tables..)
     
  5. kjsmith1026 thread starter macrumors newbie

    Joined:
    Dec 28, 2008
    #5
    I am not sure how to clear the arp cache on the ipod, but have done so on the mbp. When I initiate the ping from the mbp with the arp cache cleared, the mbp first sends an arp request and I do not see an arp reply from the ipod. When I initiate the ping from the ipod (the arp cache must be cleared when I start the ping on the ipod as an arp request is the first thing sent out), the mbp gets an arp request and responds with an arp response, but either the ipod doesn't get it or doesn't like it as it keeps sending an arp request for the mbp and no icmp pkt is received on the mbp.

    When in the mbp is in wired mode, I see the exact same thing except after the arp request/reply, the icmps are then sent just fine.

    From mbp:

    KMac:~ kjsmith$ arp -an
    ? (192.168.1.1) at 0:16:b6:83:fb:34 on en0 [ethernet]
    ? (192.168.1.2) at 0:30:1b:43:fc:56 on en0 [ethernet]
    ? (192.168.1.5) at 0:30:1b:40:18:d9 on en0 [ethernet]
    ? (192.168.1.95) at 0:20:4a:89:12:f3 on en0 [ethernet]
    ? (192.168.1.103) at 0:17:ab:ed:5d:27 on en0 [ethernet]
    ? (192.168.1.143) at 0:22:41:70:e3:22 on en0 [ethernet]
    ? (192.168.1.255) at ff:ff:ff:ff:ff:ff on en0 [ethernet]

    and the mac addr of the ipod is 00:22:41:70:E3:22, so it shows up in the arp table on the mbp (2nd to last entry).
     
  6. tylmad macrumors newbie

    Joined:
    Feb 25, 2009
    #6
    I seem to have exactly this problem.

    I have a new MacBook (2008 unibody) and an iPod 2G. The MacBook is running all sorts of servers that work perfectly on all clients on my lan except the iPod. The iPod is also running some apps that other clients can access except the MacBook. If the MacBook is connected with an ordinary cable, everything works.

    I haven't tried wireshark or checking out the ARP-table yet.

    I have posted this problem on another forum as well:

    http://discussions.apple.com/message.jspa?messageID=9052150#9052150

    hopefully someone wise and powerful will read this and help me!
     
  7. tylmad macrumors newbie

    Joined:
    Feb 25, 2009
    #7
    I just got the 3.0 update on my iPod touch and the connection problem has completely disappeared!
     
  8. Prateek jalan macrumors newbie

    Joined:
    Jun 28, 2009
    #8
    Problem connecting to Belking54g router

    Hey,
    My name is Prateek, I am from India. I recently bought a belkin router and am having problems connecting to the internet. My airport shows connected but when i try connecting to the internet the message i receive is " error in connection ". I have a WINxp desktop and the router seems to be working fine on that whereas it isn't working on my MAC OS X leopard. I am able to connect to Wi Fi in other places but this one connection is not working on my laptop. Any advice?
     

Share This Page