Wireless drop outs

Discussion in 'Mac Basics and Help' started by brettsinger, Dec 16, 2007.

  1. brettsinger macrumors member

    Joined:
    Aug 13, 2006
    #1
    I have a Macbook and the wireless connection keeps popping in and out. I'm using a linksys WRT54G router. I would blame the router but the other devices on the network (a Wii, an IBM Thinkpad with Windows XP) don't have drop out problems. Sometimes Internet Connect won't see the router at all, sometimes it will but then when I try to connect it says "there was an error connecting to the router" (might not be the exact wording). I'm using WEP. Any help is most appreciated since this problem is forcing me to use my PC which I'd rather not do. Thanks.
     
  2. EricNau Moderator emeritus

    EricNau

    Joined:
    Apr 27, 2005
    Location:
    San Francisco, CA
    #2
    Is all of your software up to date (i.e. Software Update can't find anymore updates) and is this a new problem or has your MacBook had this problem the entire time you've owned it?
     
  3. Jeremy! macrumors newbie

    Joined:
    Dec 14, 2007
    #3
    Ever since my neighbor went wireless, I've had problems to. I switched my wireless power settings to 100%, and turned on 'network robustness' I also made the network undiscoverable, and used encryption. The problems have since gone away...give it a try
     
  4. Big-TDI-Guy macrumors 68030

    Big-TDI-Guy

    Joined:
    Jan 11, 2007
    #4
    WRT54Gs - all Linksys Routers - for whatever reason - lock up after a period of time. (seems to happen more frequently if the router has a lot of traffic going through it) The easiest fix is to unplug the power, and plug it back in a couple seconds later.

    If you live in a dense area, and other networks are about - you can manually change your carrier frequency (aka channel) on the router.

    Rotate your antennas 90 degrees - and/or reposition the router, as that may help.

    Are there any metal or concrete walls between your Mac and the router? What is the distance compared to the other devices that are working?

    Any phones (cordless or cellular) or any other radio generating device near the Mac?

    Also - check the power-saving scheme on your Mac - see if there are any settings to lower WIFI radio power, or sleep the WIFI in order to conserve battery life. I don't know if Apple has this - but I've seen other laptops with this feature, and it can wreak havoc on WIFI connections.
     
  5. EricNau Moderator emeritus

    EricNau

    Joined:
    Apr 27, 2005
    Location:
    San Francisco, CA
    #5
    Microwaves can also wreak havoc on Wifi. If one was nearer to your Mac than the other computers, it could cause the problem your experiencing.
     
  6. brettsinger thread starter macrumors member

    Joined:
    Aug 13, 2006
    #6
    Lots of good things to try, thanks.
    Question: how do I set the wireless power to 100%? I can't find the setting.
     
  7. phatmansays macrumors newbie

    Joined:
    Dec 11, 2007
    Location:
    Lancaster, UK
    #7
    Hi there. Have actualy just come off the phone to apple with the very same problem... Has it been working in the past but all of a sudden given up?
     
  8. brettsinger thread starter macrumors member

    Joined:
    Aug 13, 2006
    #8
    Not all of a sudden but it was working before and now its been buggy for awhile. What did Apple tell you?
     
  9. Jeremy! macrumors newbie

    Joined:
    Dec 14, 2007
    #9
    As for the power settings it was under the 'wireless tab', but you are using a different router - so I can't help you further in that regard.....sorry.
     
  10. supersize macrumors member

    Joined:
    Nov 2, 2004
    #10
    I had the same problem with my linksys WRT54G (i think it was firmware v8) it was constantly dropping it's connection and needed to be reset all the time. I would go in spurts some days it would need to be reset 3-4 times. I did some research and found that the v8 has alot of problems and for some reason it can't be flashed to use one of the freeware drivers (older firmware versions can be flashed and that fixes the problem) which basically means I was SOL. The only solution I could come up with was to buy a Belkin router which I havent had any problems since. I know that's probably not the solution you're looking for but that's the only thing I found that worked.
     
  11. phatmansays macrumors newbie

    Joined:
    Dec 11, 2007
    Location:
    Lancaster, UK
    #11
    Hi there again sorry it has taken so long to get back. They have given me a solution which i am currently trying and it looks good so far. Firstly shut down your laptop, hold down the shift key and turn back on. Keep the shift key held down and this will boot in safe mode. Once in safe mode go to your hard drive and into the library. delete the Caches folder from here.
    Now go into the Preferences folder and move the SystemConfiguration folder onto your desktop ( this doesn't want to be deleted yet in case this doesn't fix your problem and you can put this back in). Now finally go into your home directory (with the home icon next to your name) and go into the library and delete the Caches folder out of here. Now shut down, and turn back on.

    This is what i have tried so far and seems to of fixed my problem. The only other thing the guy said was that it could be a problem with the WEP key (if you are using one). Try changing your wireless key from a 64bit key to a 128bit key because apparently Macbooks dont use 64 anymore??? sounds strange to me and i couldn't get my 128 key to work...
     
  12. brettsinger thread starter macrumors member

    Joined:
    Aug 13, 2006
    #12
    Hm. Interesting, thanks. So I guess I'll take router recommendations, since this is a really annoying problem. Which router models have you had success with?
     
  13. brettsinger thread starter macrumors member

    Joined:
    Aug 13, 2006
    #13
    Haven't tried this yet but I thought I'd share the link:

    http://tinyurl.com/2ypqcy
     
  14. macthenewblack macrumors newbie

    Joined:
    Jan 14, 2008
    Location:
    United Kingdom
    #14
    ISP DNS servers

    I had the same problem and this was echoed across the search engines with a number of solutions posed including: changing to WPA Personal from WEP, changing channels and many more. What seems to have clinched this for me is to change from the DNS server name range provided by my ISP to an open DNS server. Absolutely no problem since then.
     
  15. tominated macrumors 68000

    tominated

    Joined:
    Jul 7, 2006
    Location:
    Queensland, Australia
    #15
    this happens to me on my 2006 iMac CD. I don't have wep or any security for that matter activated.
     
  16. rockaceone macrumors newbie

    Joined:
    Dec 16, 2006
    #16
    Macbook issue

    Having done a search in Apple discussions, this seems to be a Macbook hardware issue, not so much a router issue. I have a new Macbook SR, and it definitely has issues. I can usually connect at home, but it always has less of a connection than my old ibook G3! And then, the connection goes in and out more frequently.

    I cemented my thoughts on this today at the local panera bread. I couldn't get a connection at all, and sitting right next to me, with a great (full as he said) connection was a guy with a macbook pro. Turns out... our settings are basically the same, OS the same, etc.

    Now, as I think about it, ever since I upgraded from the Ibook G3 to the Macbook (or downgraded in this case)... all of my local java houses have given me trouble with wireless. Since the range of types of routers and settings probably vary greatly from place to place... I am pretty sure the issue is with the macbook wireless receptivity.

    I'm gonna call my local Apple store (not that it will help) about it today and see what they say.
     
  17. brettsinger thread starter macrumors member

    Joined:
    Aug 13, 2006
    #17
    I thought that was it but now my Thinkpad (Windows XP Pro) is having issues as well. That said, my Linux devices (OLPC, old Dell laptop) and Wii appear to be fine. So I'm stumped.

    I think I just read that Stevey-J announced an Airport with a hard drive. That might be worth getting.
     

Share This Page