Wireless Dropouts

Discussion in 'MacBook Pro' started by SebZen, Apr 27, 2009.

  1. SebZen macrumors 6502

    Joined:
    Apr 12, 2009
    #1
    Just got a brand new MBP (unibody) and the wireless seems to be funked. Every now and then (about once every minute) wireless will stop for about 5 seconds.

    Say I'm downloading something at full speed. Sometimes it would just stop downloading and the download speed would drop, then come back once it regains internet (websites won't load either during this little downtime).

    I have another non-Mac laptop that has no problems =/
     
  2. mikeinternet macrumors 6502a

    mikeinternet

    Joined:
    Nov 1, 2006
    Location:
    Oaklnad, CA
    #2
    The wifi connection on my MBP is absolutely awful. Even side by side with my friends PC on the same network.

    When you go up to your wifi drop down menu does it say 'Airport: Scanning'?

    That's what mine does. I've had it 3 months now and haven't found any help. It is just bearably enough not to try and return it.
     
  3. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #3
    It does say scanning when I drop down but that's normal. It just scans everytime you launch time. Doesn't take more than a few seconds to find networks for me.

    I also don't want to replace my MBP because I already installed a new hard drive and memory :(
     
  4. core2duo macrumors member

    Joined:
    Apr 26, 2009
    #4
    Open up Terminal, with two windows. In one, type 'sudo ping-f google.com' (no quotes). In the other, type 'ping google.com'. Watch the latency times reported back in the second window. If you start to see the numbers getting bigger and bigger, your card is dropping the signal. Run this test against several networks. Keep records of what you find. If it turns out to be the same across all networks, make an appointment at your local Apple store, and tell the Genius what kind of testing you did and what your results were.
     
  5. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #5
    What am I doing wrong? I've let it run for about 5 minutes now and I've only gotten 2 reports so far. First was 37ms, the other was 38ms. It took about 30 seconds for the first report to show up and another minute or two for the second. Third one doesn't want to show up.

    I also tried using Network Utility to ping google. In there it says
    OK the above seems to be a problem with the OS. Connecting with an ethernet cable does the same thing. I am unable to ping google (made sure to disable AirPort, and on my router the wired light is blinking, so it is wired).

    Edit: OK figured it out. It seems that ping -f google.com made the network nuts because the router light wouldn't stop blinking (meaning there is activity). Restarted Mac and now I can ping again. Regular ping is consistent. Only a delta of ~1ms (21-22ms constant)
     
  6. dentedG4 macrumors member

    Joined:
    Jun 18, 2007
    #6
    I would check to make sure the firmware on your router is up to date.
     
  7. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #7
    It is. Just updated yesterday (I have two routers, one as backup. I tried both. One is a WRT54GS that seemed to not like the Mac at all and one is a WNDR3300 with N wireless that is doing much better but.. dropouts still now and then) [Yes, I know N is supposedly much shorter range. I tried with the G band on the 3300, same results pretty much)
     
  8. DeusInvictus7 macrumors 68020

    Joined:
    Aug 13, 2008
    Location:
    Kitchener, Ontario
    #8
    N actually has MORE range than G, but anyway, back on topic.

    I have the same problem with the wireless dropouts, but for me, it doesn't say it drops out, it still has full bars. I haven't been able to find a fix yet, but seeing as this is my uncle's network, I do not want to mess with anything to see if it is fully updated and all that. The router being in the basement doesn't help at all either :rolleyes:
     
  9. SebZen thread starter macrumors 6502

    Joined:
    Apr 12, 2009
    #9
    Yeah does the same thing for me. Bars stay full.

    And about N, I just remember when I got my 3300 (it was a good price, I didn't even have N at the time) I did some research for the firmware (wanted to put DD-WRT) and remember people saying not to use N because its very buggy and can barely go through one wall)
     
  10. kastenbrust macrumors 68030

    kastenbrust

    Joined:
    Dec 26, 2008
    Location:
    North Korea
    #10
    Thats only if you use the dual band feature alongside a G network, which defeats the whole point of using N in the first place, it reduces the N range to something that struggles to go through cardboard :rolleyes:

    My old MBP had a terrible wireless signal, but on my new 17" Uni its great, the only complaint i have about my MBP now is that the wireless card doesn't support packet injection.
     
  11. Cathode macrumors regular

    Cathode

    Joined:
    Aug 5, 2008
    Location:
    Flagstaff, AZ
    #11
    I've had some serious issues with my new MacBook Pro and wireless internet. I've heard because of the metal body, it somewhat hampers the wireless performance. I don't know if there is any actual truth to that.

    Anyway, one thing I do find interesting is I've had the majority of my network use on only three routers. One at work, one at my house and one at my Mom's house. At work we use an Apple AirPort Exteme and it works flawless. At my house I have a Linksys router (that will soon be out the window) and have problems with connectivity at least once a day. What I find disturbing is that three of the four computers in the house are all on wireless. I'm the only one who has issues with it [also the only one with a Mac]. It never goes out for anyone else, it also doesn't matter where I'm located. The connection can drop if I'm in the same room. At my Mom's house I've had problems on occasion too.

    Apple brand router, works great.
    Third party router, doesn't work on only my machine.

    /tinfoil hat

    :rolleyes:
     

Share This Page