Wireless help needed please

Discussion in 'Mac Basics and Help' started by Lambadonna, Feb 15, 2010.

  1. Lambadonna macrumors newbie

    Joined:
    Feb 15, 2010
    #1
    I have a late 2008 imac (2.8Ghz core 2 Duo) with snow leopard 10.6.2

    Ive just upgraded my Cable connection (virgin media) to 50mbs. I can connect via ethernet to my wireless modem and I do indeed get 50mb/s. However wirelessly i get about 26mb. The Airport extreme card installed says it N compatible (according to system profiler).... and my d-link wireless router says that its connected via 802.11 n.

    I just cant get it up to 50mbs. Its not a big deal as I can connect via ethernet...but its annying me as It should work...shouldnt it.

    Any help gratefully accepted...it may be me being a bit thick.:)
     
  2. Lambadonna thread starter macrumors newbie

    Joined:
    Feb 15, 2010
    #2
    Should have mentioned that my iphone connects at 50mbs.....just not the imac...its driving me nuts.
     
  3. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #3
    Is the firmware of the D-Link and your Airport at the latest revision?
     
  4. Lambadonna thread starter macrumors newbie

    Joined:
    Feb 15, 2010
    #4
    Airport firmware version - Broadcom BCM43xx 1.0 (5.10.91.26)

    How do i tell whether this is the latest?

    I believe the d-link is up to date

    Thx in advance
     
  5. snberk103 macrumors 603

    Joined:
    Oct 22, 2007
    Location:
    An Island in the Salish Sea
    #5
    Also, there may be wireless interference from other sources. Have tested the wireless speed with the iMac right next to the router? Have you tried changing channels?
     
  6. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #6
    NO wireless device gets 100% bandwidth

    Real life speed is affected by various things, but typically don't go up above 80% under ideal conditions.
     
  7. Lambadonna thread starter macrumors newbie

    Joined:
    Feb 15, 2010
    #7
    I downloaded the Speedtest.net Iphone app form the app store. I ran a test and it came back with 49 Mbs. I was sat at the desk in front of the imac!!
     
  8. Lambadonna thread starter macrumors newbie

    Joined:
    Feb 15, 2010
    #8
    Do I change channels on the router...or the Imac? I guess both but does one follow the other?
     
  9. snberk103 macrumors 603

    Joined:
    Oct 22, 2007
    Location:
    An Island in the Salish Sea
    #9
    I believe the router. Do some reading about channels, there are some easy to read manuals on which channels are most likely to interference-free. But off the top of my head, its the middle channel, and the two channels at either end - so, again off the top of my head - channels 1, 6 and 11. But if I'm wrong about the details it'll be something similar.

    If you're in North America there's this link to test your actual speeds.

    Good Luck
     
  10. Lambadonna thread starter macrumors newbie

    Joined:
    Feb 15, 2010
    #10
    Finally fixed this.

    For anybody else out there struggling with this issue..you can find the help needed here:-

    http://www.virginmedia.com/help/wireless/nrouter-faqs.php

    Essentially you have to use WPA Personal or WPA2 Personal as the security setting....anything else wont work and you will be capped at "g" speeds not "n"

    The virgin media people hadnt a clue how to fix this (installation or telephone technical).... ! I guess its on their web site so I shouldnt complain too much.

    Change your security setting on the router and re-join the wireless network with the new password and away you go...I get 45mb/s now...cool


    :D
     

Share This Page