Wireless internet connection disconnects

Discussion in 'iMac' started by WIFF, Sep 8, 2008.

  1. WIFF macrumors newbie

    Joined:
    Sep 8, 2008
    #1
    Hi.
    First off, I'm a newb to the Mac world, but not to computers or forums. I've tried searching to no avail. Here's my problem:
    I just got a new iMac 24" 2.8GHz with 4GB RAM. I connect to the internet rather easily through AirPort (via my DSL connection to a router in the other room.) I am running WEP, and can access the wifi net, and even surf. The problem I have is that if I get up and walk away for about 5-10 minutes, the connection breaks. I then have to go back and allow airport to "find" the network, and then supply the password again to get back on the net. It is really annoying, especially if I am running something that needs the net connection, like system update. I have full bars on the airport icon.
    I have searched the forum for this problem, but so far haven't found any posts that sound similar to my problem. Is there a configuration tweak I can do to get airport to stop disconnecting, or if it does disconnect, can it reconnect without asking me for my password every time?!

    Thanks in advance,

    WIFF
     
  2. yellowcanary73 macrumors newbie

    Joined:
    Sep 2, 2008
    Location:
    McKinney,Texas
    #2
    I read somewhere on Apple support site with others having problems most seem to think it started after they did an up date.

    http://discussions.apple.com/thread.jspa?threadID=1603263&tstart=0
    http://www.appleinsider.com/articles/08/09/02/briefly_mac_os_x_10_5_5_to_address_airport_glitch.html
     
  3. deedlit78 macrumors newbie

    Joined:
    Sep 9, 2008
    #3
    how to post a question on these things

    i'm new to forums and i'm not sure how to go about posting my questions. help please!!!!:confused:
     
  4. gixxerfool macrumors 6502a

    gixxerfool

    Joined:
    Jun 7, 2008
    #4
    I have been having the same problem with my Mini. So I borrowed a USB wireless adapter to see if that solved it, no dice there either. If anyone can help it would be appreciated.

    And for deedlit find the thread that best fits your question, go in there and then click on new thread in the upper right hand corner.
     
  5. serega macrumors regular

    Joined:
    Nov 19, 2007
    Location:
    Seattle
    #5
    I have same problem for almost a year since I got my Imac. Same way every time it asks for a key (WEP) even it stored in a keychain. My wife's Vista and my Toshiba notebook (XP) have no issues with that. I did not find solution to that and always check this forum to see if some one did.:confused:
     
  6. sash macrumors 6502a

    sash

    Joined:
    Nov 23, 2004
    #6
    Hi,

    I don't think this is a hardware issue, but rather a software one, introduced in Leopard and still not fully worked out.

    sash
     
  7. alienprdkt macrumors newbie

    Joined:
    Oct 4, 2008
    #7
    For linksys routers I turned SSID Broadcast to disable ( When wireless clients survey the local area for wireless networks to associate with, they will detect the SSID broadcast by the Router. To broadcast the Router SSID, keep the default setting, Enable. )

    Without your SSID being broadcasted I also disabled my security encryption for my wireless (bout 300 feet) figured that if my SSID doesn't show up then i should be ok within my neighborhood, and besides this is the only way that i have found to keep a connection between my mac osX Leopard and my Linksys wireless router.

    Hope this helps out with the wireless problems...
     
  8. beaucage macrumors newbie

    Joined:
    Jan 11, 2009
    #8
    wireless disconnect problem os x simple solution: Remove Superflous Login Items

    I believe I may have solved the mac os x wireless disconnect problem, at least for my system (Black MacBook core II duo running 10.5.6). I have had all of the symptoms noted on several web pages including random disconnect, frequent disconnect, message that the wireless router has been compromised. These all seemed to happen after a system update (some state that 10.5.2 is the last stable version for wireless).

    The problem disappears when you boot on the install disk (10.5) and don't use the install program but just connect to the internet using the menu bar wireless icon, selecting your wireless router from the pull down menu. That is the internet connection is stable given by the strong signal (black bars), though you can't use a web browser in this setup as far as I know. This seems to be a reasonable and simple test to see if this is an operating system or hardware problem and was suggested in another post.

    The problem seems to be solved after I went to System Preferences (Apple Menu):System: Accounts:
    Choose menu item "Login Items" and delete all superfluous Login items such as Adobe updater and some other updater programs. I now have only SideTrackSessionAgent, Google Notifier, iTunesHelper, SuperDrive Update 2.1, and Remote Buddy as Login Items. After removing all superfluous Login items I rebooted. The wireless seems to be working fine for 4 hours with no disconnect. (Prior to this it would disconnect after about 5 to 10 minutes, 30 minutes at the most.)

    One theory why this works may be that some of the other offensive Login Items were attempting to connect to their home site periodically (every 5 or 10 minutes say) and this caused some type of conflict with the updated OS X wireless security leading to a disconnect or other intermittent behavior depending on the specific nature of the wireless connection.

    It would be nice to know if this works for others. I believe it is consistent with the solution of reinstalling an early version (5.2) of OS X and skipping updates which some have noted also clears up the problem.

    Good luck and I hope this helps.
     
  9. galstaph macrumors 6502a

    galstaph

    Joined:
    Jul 24, 2002
    Location:
    The Great White North Eh
    #9
    had this issue on my ibook before the airport card crapped out (infamous airport connector issue that is the bane of the last gen ibook, regardless of apple's refusal to admit it).
    Assign your mac a static ip address (setting aside a certain one (192...01 or whatever) on your router setup and corresponding to your airport ip setting in system prefs). This solved it for me, worth a try I'd say
     

Share This Page