Wireless internet failure on XP but not OS 10.5

Discussion in 'Mac Basics and Help' started by j2p4h, Aug 6, 2008.

  1. j2p4h macrumors newbie

    Joined:
    Aug 6, 2008
    #1
    Hi, I'm new to macs and new to this forum, though I've searched a long time to try to find a way to fix this problem.

    I am running OS 10.5 and it has no issues with connectivity on my wireless network. As well, a PC computer in my house has no issues connecting to this same wireless network on a cheap USB reciever so this is quite vexing for me.

    While running XP Home SP2, enabling either WPA or WPA2 (I've tried both but I am confident based on the router that it is just WPA), I have been unable to connect to my network. Windows tells me it is connecting to the network after I give it the WPA password and displays a loading bar for a period of time before it gives up and the loading window goes away, the network still unconnected. I have tried connecting in the same way at a friend's house to a WPA encrypted network and got the same result, where others were able to connect, although on PCs.

    If I disable the encryption on my router or change it to a WEP encryption, I can connect to the network wirelessly but internet connectivity is weak and occasionally cuts out. This is not my greatest concern, however.

    I can connect to the network on XP with a wired connection. I have loaded all the drivers from the Leopard disc and reloaded them just to be sure.

    I would like to know if this is a hardware problem and I should bring it in somewhere for service or if I just need to change some settings or possibly load a third party program to manage my connection.

    Hardware:
    MacBook Pro (Shipped with 10.5)
    NETGEAR WGR614 v4 Router

    Thanks and I apologize in advance if I've missed any critical details or this exact problem has come up before and I've just missed it in my searching. I don't know the details of the network at the friend's house, unfortunately.
     
  2. MarkMS macrumors 6502a

    Joined:
    Aug 30, 2006
    #2
    So you are running XP on Bootcamp? Have you tried running the Apple software update in XP? There is a new set of drivers, but I'm not sure if you downloaded/installed them yet.

    If you have done the Bootcamp driver update, then I think this is probably an XP software issue. Microsoft issued a WPA/WPA2 update a while back and you may not have it installed. Try installing this patch from Microsoft.

    http://www.microsoft.com/downloads/...FamilyID=662bb74d-e7c1-48d6-95ee-1459234f4483

    If that doesn't work, just try installing all XP updates including SP3 from Windows Update in the Start menu.

    Let us know if this helps or not.
     
  3. j2p4h thread starter macrumors newbie

    Joined:
    Aug 6, 2008
    #3
    Yes, I am running XP on Bootcamp. I have installed the WPA2 patch already. Recently I have tried the Apple software update you suggested and it completed successfully but did not serve to solve my problem at all. Currently, my Windows software updates automatically but when I try to use Windows software update on the Microsoft site the download window appears but will not download at all no matter how long I wait. No progress is displayed in the loading bar.

    I could call customer support or a store that repairs computers but I have a feeling Apple will blame Microsoft and vice-versa. Do you think this will be the case or have any other suggestions? Perhaps URLs of Microsoft patch download sites to get around the actual Windows update process? I am not sure which updates I'm looking for or where to find which ones I already have.
     
  4. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #4
    You can try uninstalling the driver and reinstalling it this can sometimes clear up driver issues. Upon reboot Windows will probably reinstall the driver automatically.
     
  5. j2p4h thread starter macrumors newbie

    Joined:
    Aug 6, 2008
    #5
    I tried the suggestion about uninstalling the driver and the driver did reinstall automatically upon my restarting, as supposed, but this has produced no progress in solving this problem. Any other suggestions? (Thanks so far for trying by the way).
     

Share This Page