Wireless internet via Linksys router...

Discussion in 'MacBook Pro' started by jpa.herron, Feb 9, 2007.

  1. jpa.herron macrumors newbie

    Feb 9, 2007
    Hi guys,

    Recently made the switch from Windows to a 17" MBP (not even a week old). I'll be setting Windows up on it in the near future, for work purposes, but I have to say I couldn't be more impressed with it as it is.

    Quick question... I have wireless broadband setup at home using a Linksys WRT54G router. Security is enabled (WEP 128bit... I think), & everything seems to operate well on the PC side. Tried connecting the MBP wirelessly to the network. It finds the SSID, but I can't get past the password dialogue... says an error occured. Using the password that I setup through Windows isn't accepted. I've tried entering the code generated from the password, but still can't get through. Plugging the ethernet cable in gives me wired access, but surely this should be a simple problem to solve.

    I've tried accessing the router to check security settings, but everytime I enter the Basic Setup page (, then enter the administrator's password), the page doesn't seem to load properly. Not all of the settings are displayed, & I can't select anything to change it. I've tried it on three separate machines (the MBP & two PCs), but the result is the same.

    Am I doing something wrong? Is there a compatibility problem with the encryption (WPA, WEP, etc.)? Can anybody recommend the best encryption on a wireless network using both Macs & PCs?


  2. devilot Moderator emeritus


    May 1, 2005
    I think this is that silly trip up...

    When you input the password, try placing a "$" before the password.
    Say your password is 12345hi, then try: $12345hi.

    :eek: I dunno if this is the problem at all, I just know that in the past, when I've used passwords to access a wifi network, that's what it took.
  3. diadem macrumors regular

    Nov 13, 2006
    Change to WPA2 and you dont need to do anything other than put in the passphrase as normal no $ in front. I have a WRT54G as well and it works fine.
  4. logandzwon macrumors 6502a

    Jan 9, 2007
    I used to have a wrt54 router when I first my 17 mbp. The mbp could stay connected very long before it would just disconnect. I ended up just getting an apple airport to fix the issue. Whoever, the issue does not seem to happen anymore when I'm at someone else's house that has a wrt54g. I never had hte issue you talk about though.
  5. jpa.herron thread starter macrumors newbie

    Feb 9, 2007
    Don't remember seeing an option for WPA2 when I first set everything up...

    do I need a firmware upgrade?
  6. Cerebrum macrumors regular


    Mar 31, 2006
    Boston, MA
    Reset your router as a WEP password protected, as in my experience, it has usually worked better. Aside from this, linksys routers suck for Apple products. I have used many linksys routers, and I have always had issues with them and with my PowerBook. Once in WEP, you may have to use the $ sign in front of your passwork, sometimes you don't have to.

    If you really want the WPA2 network, choose "Other" in your AirPort choices and then put in the Network SSID and under security choose what best applies. There is the WPA Personal, WPA Enterprise, WPA2 Personal (probably your choice), WPA2 Enterprise, and 802.1X WEP. Then put in your password.

    - C.M.Sevilla
  7. jpa.herron thread starter macrumors newbie

    Feb 9, 2007
    Thanks guys,

    My biggest problem is that I can't see the Basic Setup screen when I access the router. Been checking out this issue on other forums, but nobody seems to have a solution. Others have suggested the problem is firmware related.

    If I could access the router, I think I could sort out the rest.

    Any suggestions?

Share This Page