Wireless is unreliable and awful!

Discussion in 'MacBook Pro' started by RichardJohn, Oct 24, 2007.

  1. RichardJohn macrumors member

    Joined:
    May 12, 2006
    #1
    I set up wireless this afternoon. All my Windows machines connected fine, and have been working since, but my Macbook is being stubborn.

    First, it wouldn't connect at all if there was encryption "There was an error joining Airport network..." (a really helpful error :rolleyes:). I then updated the Airport driver, and now it can't see the access point.
    I have to click "Other...", put in the SSID and WPA key, and then connect. It will then give the first error, but when I click ok, I can then connect by clicking the menu icon. If I then disconnect, it disappears and I have to repeat the process.
    The connection also stops working occasionally. It's not the signal, as the router is in the same room, but the wireless light on the router stops flashing, so it's as if the Macbook has stopped sending signals completely. I then have to disconnect, and reconnect using the above method!

    Does anyone know what's causing this? My Toshiba laptop and HP desktop are working flawlessly on the same network.
     
  2. rychencop macrumors 65816

    rychencop

    Joined:
    Aug 17, 2007
    Location:
    http://www.northaugusta.net/
    #2
    I have not had that issue, but I will say that connecting via the MBP airport card is not very good at all. My Dell never had an issue, but my Mac is very funny about the strength of the signal and it will "hang" at times for no real reason.
     
  3. RichardJohn thread starter macrumors member

    Joined:
    May 12, 2006
    #3
    I think the second problem actually is "hanging", as if I leave it for an amount of time (anything from 10 seconds to a minute), it starts working again.
    Interestingly, my friend had a problem with his MBP getting the "error connecting to..." message, so I went and reset his router for him!

    Looks like the problem is with Airports, though.
     
  4. TheStu macrumors 65816

    Joined:
    Aug 20, 2006
    Location:
    Carlisle, PA
    #4
    What router are you using? I have used Netgear routers almost exclusively for the past 4 years, and have never had an issue connecting to them on my MacBook, and the same goes for my friend that uses DLink routers. I have found that Linksys doesn't always play nice with macs, so you might want to see about that.

    Past that though, call Apple and see about getting it fixed.
     
  5. vanmacguy macrumors 6502a

    Joined:
    Aug 13, 2007
    Location:
    Not where you live.
    #5
    I had a similar problem with a Linksys router and found that I needed to upgrade the firmware.

    Once I did that the problems all went away.

    So check and see if there's an update for your routers firmware.

    Cheers.
     
  6. RichardJohn thread starter macrumors member

    Joined:
    May 12, 2006
    #6
    It's a Netgear WG834G v3. I'll try updating the firmware.
     
  7. hishat macrumors regular

    hishat

    Joined:
    Oct 14, 2007
    Location:
    United Kingdom
    #7
    i had that same problem..

    i'll tell you how i got around it...

    go into your router homepage...usually begins with 192. and change the channel of your wireless signal...i did that...and now iv been workin on my macbook...2days without a single drop out!! let me know if it works :)
     
  8. TheStu macrumors 65816

    Joined:
    Aug 20, 2006
    Location:
    Carlisle, PA
    #8
    Or perhaps turn off 802.11B broadcasting

    if it is netgear then it should be http://192.168.1.1

    user and pass are printed on the bottom of the router unless you changed them
     
  9. RichardJohn thread starter macrumors member

    Joined:
    May 12, 2006
    #9
    I dropped down to channel 2, and it's been stable since.

    Out of interest, what difference does using G only make?
     
  10. TheStu macrumors 65816

    Joined:
    Aug 20, 2006
    Location:
    Carlisle, PA
    #10
    You know, I honestly don't know. I have just noticed that it helps sometimes, if the router has as few things as possible to concentrate on, especially if your router wasn't designed to handle lots of connections at once. Which, reminds me, although you have it working fine now, how many machines are connected to it wirelessly?
     
  11. RichardJohn thread starter macrumors member

    Joined:
    May 12, 2006
  12. unixham macrumors newbie

    Joined:
    Apr 13, 2007
    #12
    Please please please for your (and your neighbors) sake. Use ONLY 1, 6, and 11 and encourage others to do the same.

    Channels are only the base frequency of a frequency band that is 5 channels wide. 2 smashes 1 by being offset and 6 by covering the bottom of it, neither can hear the other, hence no collision detection, just interference. This is bad.

    Also a quick google finds:
    http://www.macgeekery.com/hacks/hardware/optimizing_airport_connectivity

    Good luck.
     
  13. cyclingplatypus macrumors 6502a

    cyclingplatypus

    Joined:
    Mar 15, 2007
    Location:
    Earth
    #13
    Are you using 10.4.10? I found that this update pretty much rendered my wifi connection useless and it is a very common problem according to the Apple discussion forum...I have the same situation and I am the only one using the channel and my wife's Windows Laptop has zero problem I even bought a new router to see if this would fix it.

    I'm really hoping that 10.5 fixes this, if it does it is worth the price for just that IMO :D
     
  14. cyclingplatypus macrumors 6502a

    cyclingplatypus

    Joined:
    Mar 15, 2007
    Location:
    Earth
    #14
    Good news on this front after installing 10.5 I've had zero dropouts or loss of signal. Before I'd get them after about 30 minutes or so, haven't had anything of the sort for the last 3 hours :D
     

Share This Page